Bug 23573 - e2label does not work with the 2.4.0 kernel
e2label does not work with the 2.4.0 kernel
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: e2fsprogs (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-08 06:58 EST by Alain D D Williams
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-16 03:47:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alain D D Williams 2001-01-08 06:58:08 EST
The format of /proc/partitions has changed, so that instead of getting a
line like:
	   3     1      48163 hda1
you will find a line like:
	   3     1       4000 ide/host0/bus0/target0/lun0/part1
 and it doesn't like it. (The above 2 lines are from different machines,
but show the format change.)

The workaround is to change the entries in /etc/fstab.
Comment 1 Bill Nottingham 2001-01-08 18:20:19 EST
You're using devfs. This makes a very large difference - without devfs,
the names are the same.
Comment 2 Florian La Roche 2001-05-16 03:47:11 EDT
Does it work with e2fsprogs-1.20-0.02 or higher from rawhide?
I have also uploaded that version to http://people.redhat.com/laroche/
Comment 3 Florian La Roche 2001-06-29 06:29:00 EDT
Should work with newer e2fsprogs tools, otherwise please open a new
bug-report.

Thanks,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.