Bug 235749 - e100 nic driver duplex mismatch (RHEL5)
e100 nic driver duplex mismatch (RHEL5)
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andy Gospodarek
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-09 18:06 EDT by Dax Kelson
Modified: 2014-06-29 18:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 11:15:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dax Kelson 2007-04-09 18:06:03 EDT
Description of problem:
We have a classroom full of Dell Dimension 4600s that have had RHEL3, RHEL4, and
now RHEL5 installed on them.

We've never had NIC / switch duplex mismatch issues until now.

The PCs have intel motherboards with the following (e100 driven) nic:

02:08.0 Ethernet controller: Intel Corporation 82562EZ 10/100 Ethernet
Controller (rev 02)
        Subsystem: Dell Unknown device 0155
        Flags: bus master, medium devsel, latency 64, IRQ 209
        Memory at fe7ff000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at cec0 [size=64]
        Capabilities: [dc] Power Management version 2

The switch is a 10/100Mb HP 4000M.

With RHEL5 and the 2.6.18-8.el5 kernel, very often (always?) the NIC comes up at
100Mb half duplex while the switch is at 100Mb full duplex causing major problems.

For now we are working around the problem with:

ETHTOOL_OPTS="speed 100 duplex full autoneg off"
Comment 1 Andy Gospodarek 2007-04-26 10:38:13 EDT
(Sorry its taken me so long to post this first message, I thought I'd posted
something last week....)

I was finally able to install a RHEL5 kernel on my 4600 that had the same part
number as yours (my other 4600 had device 0177 instead of 0155), but I don't
seem to have any problems linking up at 100-Full with my unmanaged 5-port
Linksys switch.  

Could you send the output of 'ethtool eth0' and 'ethtool -i eth0' as well as the
output from 'dmesg' when the device autonegotiates to 100-Half?

I am also going to work on a debug patch that will hopefully help us track this
down, but that might take me a day or two.

Comment 2 Andy Gospodarek 2007-04-27 17:11:11 EDT
It looks like there is already some decent debug into there, so if you can add
the module parameter to set 'debug=16' for the e100 driver that would help
gather some data when a failure happens.
Comment 3 Andy Gospodarek 2008-04-08 11:15:57 EDT
This bug has seen no activity in quite a while, so I can only presume it is no
longer a problem.  If there is still an issue that needs to be resolved, please
re-open this bug and I will be happy to help resolve it.  Thank you.

Note You need to log in before you can comment on or make changes to this bug.