Bug 23575 - xfs dies when using TrueType fonts
xfs dies when using TrueType fonts
Status: CLOSED DUPLICATE of bug 22538
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-01-08 07:51 EST by Bill Crawford
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-01-08 07:54:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bill Crawford 2001-01-08 07:51:02 EST
I have had xfs running happily for some time using a bunch of TrueType
fonts in /usr/share/fonts/default/TrueType, including the webfonts package.

After upgrading to the Rawhide packages (XFree86-4.0.2-0.2,
freetype-2.0.1-something) the font server dies as soon as a TrueType font
is referenced (in my case when WindowMaker starts, which confused me for a

Symptoms are that WindowMaker fails to start up properly, and after a few
seconds X server dies.
Comment 1 Bill Crawford 2001-01-08 07:54:25 EST
Oh, it appears to work OK under earlier kernels (2.4.0-prerelease is OK) but not
2.4.0-final or -ac patches.

Really annoyingly it works fine on my AMD K6-III at home with almost exactly the
same setup (maybe different fonts?) but fails here on my PII.

So I'm guessing there's some issue with MMX or SSE instructions?

Comment 2 Bernhard Rosenkraenzer 2001-01-08 10:11:51 EST

*** This bug has been marked as a duplicate of 22538 ***

Note You need to log in before you can comment on or make changes to this bug.