Bug 235751 - Splash screen stays open
Summary: Splash screen stays open
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: azureus   
(Show other bugs)
Version: 6
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Anthony Green
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 236191 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-09 22:35 UTC by Peter faric
Modified: 2008-01-15 23:04 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-03 17:07:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter faric 2007-04-09 22:35:35 UTC
Description of problem:
After starting Azureus (2.5.0.4) with the "show splash screen" set to ON the
splash screen stays open indefinitely at the "Opening views" stage even though
the program's main screen is up and running. 

Version-Release number of selected component (if applicable):
2.5.0.4

How reproducible:
Always

Steps to Reproduce:
1. yum update azureus
2. azureus
3.
  
Actual results:
Splash screen stays open indefinitely.

Expected results:
Splash screen closes after main screen shows up.

Additional info:

Comment 1 David Juran 2007-04-17 06:13:11 UTC
*** Bug 236191 has been marked as a duplicate of this bug. ***

Comment 2 Paul Jenner 2007-04-29 13:59:07 UTC
Following exception is logged to console:

DEBUG::Sun Apr 29 13:48:45 GMT
2007::com.aelitis.azureus.core.impl.AzureusCoreImpl$8::runSupport::-1:
  java.lang.NullPointerException
   at org.gudy.azureus2.ui.swt.updater2.SWTUpdateChecker.initialize(Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.mainwindow.Initializer$4.started(Azureus2.jar.so)
   at com.aelitis.azureus.core.impl.AzureusCoreImpl$8.runSupport(Azureus2.jar.so)
   at org.gudy.azureus2.core3.util.AEThread.run(Azureus2.jar.so)

Comment 3 Paul Jenner 2007-04-29 14:02:22 UTC
Running with another VM (JamVM) to get line numbers:

DEBUG::Sun Apr 29 15:01:05 British Summer Time
2007::com.aelitis.azureus.core.impl.AzureusCoreImpl$8::runSupport::512:
  java.lang.NullPointerException
   at
org.gudy.azureus2.ui.swt.updater2.SWTUpdateChecker.initialize(SWTUpdateChecker.java:67)
   at
org.gudy.azureus2.ui.swt.mainwindow.Initializer$4.started(Initializer.java:258)
   at
com.aelitis.azureus.core.impl.AzureusCoreImpl$8.runSupport(AzureusCoreImpl.java:508)
   at org.gudy.azureus2.core3.util.AEThread.run(AEThread.java:69)

Comment 4 Paul Jenner 2007-05-11 19:15:28 UTC
Reproduced using OpenJDK so this is an Azureus (package) issue and not VM issue.

Comment 5 Anthony Green 2007-05-11 19:40:42 UTC
Upstream says this is a bug in SWT, and they've fixed it in the SWT they bundle
with Azureus.  We use the Eclipse SWT, so we don't have the patch.  I don't know
what the fix is yet.

Comment 6 Jonathan Steffan 2007-06-02 05:15:31 UTC
I'll confirm this.

Comment 7 drago01 2007-06-02 05:28:00 UTC
(In reply to comment #5)
> Upstream says this is a bug in SWT, and they've fixed it in the SWT they bundle
> with Azureus.  We use the Eclipse SWT, so we don't have the patch.  I don't know
> what the fix is yet.

what about ccing the eclipse maintainer(s) ?

Comment 8 Chris Spencer 2007-06-17 04:32:03 UTC
I've confirmed this problem exists for F7 as well, using either GCJ or Sun Java.

Comment 9 Julian Sikorski 2007-09-13 21:16:50 UTC
IcedTea does not help either.

Comment 10 Julian Sikorski 2007-09-13 21:28:36 UTC
CCing the eclipse maintainer.

Comment 11 Andrew Overholt 2007-09-13 21:36:35 UTC
Can we get the actual SWT patch?  How about an eclipse.org bug #?

Comment 12 Lillian Angel 2007-12-03 17:07:40 UTC
Updated to azureus-3.0.3.4-1.fc9. 
Should be available tomorrow in rawhide.

Comment 13 Fedora Update System 2008-01-15 23:04:39 UTC
azureus-3.0.3.4-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.