Bug 23576 - IPv6 Support in initscripts
IPv6 Support in initscripts
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
: FutureFeature
Depends On: 26368
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-08 09:00 EST by Arthur van Leeuwen
Modified: 2014-03-16 22:17 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-02 17:37:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arthur van Leeuwen 2001-01-08 09:00:43 EST
Peter Bieringer has GPL'd his additions to the RedHat Initscripts to
support IPv6. It would be very nice to add this to the initscripts package,
as it does not break things, yet adds functionality.
The scripts (and their documentation) can be found at
http://www.bieringer.de/linux/IPv6/IPv6-HOWTO/scripts/current/index.html
Comment 1 Daniel Roesen 2001-01-08 14:02:25 EST
Strongly seconded.
Comment 2 Pekka Savola 2001-01-10 13:49:01 EST
If you're lucky[?] enough to be directly connected to IPv6 network e.g. 6bone, there is no need for any
scripts unless you want to set up some special routes.

But nevertheless, including these or similar behaviour would be A Good Thing.  
As making IPv6 work out of the box in general.



Comment 3 Bill Nottingham 2001-01-29 17:19:39 EST
These scripts (modified with a lot of the extraneous debugging/output removed)
will be in 5.60-1.
Comment 4 Peter Bieringer 2001-01-31 18:58:52 EST
>------- Additional comments from pekkas@netcore.fi 2001-01-10 13:49:01 -------
>        If you're lucky[?] enough to be directly connected to IPv6 network e.g. 6bone, there is no need for any
>         scripts
That's right for client side but for server side 

>        unless you want to set up some special routes.
Which would be the case on a IPv6 router (& local tunnel endpoint) side (until hierachical router renumbering works...) which was the first intention for the 
set of scripts.

>------- Additional comments from notting@redhat.com 2001-01-29 17:19:39 -------
>         These scripts (modified with a lot of the extraneous debugging/output removed)
>         will be in 5.60-1.
Is this snapshot already available? Can I get back the modified script set - or the URL?
Because I plan to make a minor review in the next days or week because of requests I got relating setup only the tunnel interface without special 
configuration to use automatic tunneling.

Also I'll try to mark the debug code for a quick removing in preparing for "public" releases - but this step I can only do if I see, what was removed in the 
rawhide release.

BTW: Is already the work done relating a radvd-RPM, which is needed for an IPv6 Linux router to support automatic IPv6 configuration on local clients
BTW2: Is already work in progress for an add-on on the linuxconf network configuration module?

TIA,
 Peter






Comment 5 Pekka Savola 2001-02-01 18:34:04 EST
Peter: this is now available at  ftp://ftp.redhat.com/rawhide/SRPMS/SRPMS/
Comment 6 Bill Nottingham 2001-02-01 18:40:32 EST
More or less, yes. It's still pushing to one of the servers.

The majority of my changes are:

- removing the \a from the messages (personal preference, consistency)
- removing some of the informational output for quieter startup
- marking some of the messages for translation
- removing the stuff that tweaked stuff in /proc/sys (that's what
/etc/sysctl.conf  is for)

As for your other two questions, I can pretty much state that as
far as what Red Hat is doing, no and no.
Comment 7 Peter Bieringer 2001-02-01 19:30:20 EST
Ok, got the package - will dig into tomorrow.

BTW: A minor revision of my set is currently on beta testing, I've enabled in  
simple way automatic tunneling without setup of static tunnels via a new 
interface configuration "ifcfg-sit0" [was easy to implement].

But I got another request to move routing and tunneling stuff away from 
interface configuration.
My current set of scripts was for easy add-on implementing without major changes 
in RedHat original scripts.

But now at rawhide its perhaps a good idea to implement routing and tunneling 
into /etc/rc.d/init.d/network, taking information from 
/etc/sysconfig/static-routes (extra or not extra for IPv6). automatic tunneling 
can be also enabled here at the beginning.

What's your opinion?

Until then my steps are now following:
* Backpatch your changes...
* Tag all major debug code in my originals so for public releases it can be 
removed fast using grep



Comment 8 Pekka Savola 2001-02-01 19:46:17 EST
Just in case you're interested, I just spiced up radvd (vital if you want to make a IPv6 router for e.g. your lan)
to make it look more like a prime time (and RH-lookalike :-) candidate.

The original:

http://www.bieringer.de/linux/IPv6/status/IPv6+Linux-status-conf.html

My %changelog:

* Fri Feb 02 2001 Pekka Savola <pekkas@netcore.fi>

- Create a single package(source) for glibc21 and glibc22 (automatic
Requires can handle this just fine).
- use %{_mandir} and friends
- add more flesh to %doc
- streamline %config file %attrs
- streamline init.d file a bit:
   * add a default chkconfig: (default to disable for security etc. reasons; 
     also, the default config isn't generic enough..)
   * add reload/condrestart
   * minor tweaks
   * missing: localization support (initscripts-5.60)
- use %initdir macro


basically this should work just fine with rpm --rebuild on both RHL6x and RHL7.

Available at http://www.netcore.fi/pekkas/linux/ if you wish to check it out.
Comment 9 Pekka Savola 2001-02-02 17:36:44 EST
It seems that IPv6 wasn't actually enabled in the SPEC file.

---
@@ -187,6 +187,7 @@
 %dir /etc/sysconfig/network-scripts
 %config(noreplace) %verify(not md5 mtime size) /etc/adjtime
 %config(noreplace) /etc/sysconfig/init
+%config(noreplace) /etc/sysconfig/static-routes-ipv6               <-- or perhaps as .example in %doc
 /etc/sysconfig/network-scripts/ifdown
 %config /sbin/ifdown
 %config /etc/sysconfig/network-scripts/ifdown-post
@@ -195,6 +196,7 @@
 %dir /etc/sysconfig/console
 %config(noreplace) /etc/sysconfig/rawdevices
 %config /etc/sysconfig/network-scripts/network-functions
+%config /etc/sysconfig/network-scripts/network-functions-ipv6
 %config /etc/sysconfig/network-scripts/ifup-post
 %config /etc/sysconfig/network-scripts/ifcfg-lo
 %config /etc/sysconfig/network-scripts/ifdown-ppp
@@ -205,6 +207,11 @@
 %config /etc/sysconfig/network-scripts/ifup-plip
 %config /etc/sysconfig/network-scripts/ifup-aliases
 %config /etc/sysconfig/network-scripts/ifup-ipx
+%config /etc/sysconfig/network-scripts/ifup-plusb
+%config /etc/sysconfig/network-scripts/ifup-ipv6
+%config /etc/sysconfig/network-scripts/ifdown-ipv6
+%config /etc/sysconfig/network-scripts/ifup-sit
+%config /etc/sysconfig/network-scripts/ifdown-sit
 %config /etc/X11/prefdm
 %config /etc/inittab
 %dir /etc/rc.d
---

This also adds ifup-plusb (no ifdown-plusb there) which might also have been left out by accident.

These files should also be chmod +x'd in the source tree.
Comment 10 Bill Nottingham 2001-02-02 18:25:03 EST
Whoops, fixed, will be in 5.61-1.

As for moving the stuff into /etc/sysconfig/network, one of the
reasons this was able to be added now is that there wasn't a chance
of causing any problems if you didn't use it; if it's in /etc/sysconfig/network,
that's not the case (Yes, I'm paranoid.)

Note You need to log in before you can comment on or make changes to this bug.