Bug 235761 - MP-BIOS 8254 Timer not connected to IO-APIC - GA-M59SLI-S5
MP-BIOS 8254 Timer not connected to IO-APIC - GA-M59SLI-S5
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-09 19:32 EDT by Gerald Cox
Modified: 2007-11-30 17:12 EST (History)
5 users (show)

See Also:
Fixed In Version: BIOS m59slis5.f8g
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 04:36:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Cox 2007-04-09 19:32:00 EDT
Description of problem:
Receive MP-BIOS bug:  8254 timer not connected to IO-APIC
Not syncing:  IO-APIC + timer does not work
Then system hangs with Panic
Motherboard is a Gigabyte:  GA-M59SLI-S5 running latest BIOS Version F7

Version-Release number of selected component (if applicable):
Running FC7 - Test 3

How reproducible:
Boot from install DVD

Steps to Reproduce:
1.  Boot from installation DVD

Actual results:
Receive above message, followed by kernel panic


Expected results:
Normal boot

Additional info:
Am able to boot using NOAPIC option
Comment 1 Matthew Miller 2007-04-10 12:31:08 EDT
Fedora 7 test bugs should be filed against "devel", not against test1/2/3. This
isn't obvious, I know. Moving this report so it isn't lost.

This is a bulk message -- I apologize if this was actually meant to be targeted
against a different release. If so, please fix or let me know. Thanks.
Comment 2 Darlene J. Ford 2007-07-03 19:59:10 EDT
This sounds similar to 175784, which has been reported in RHRel4 and Fedora 5.  
The boot args mentioned there may be worth a try.  
Comment 3 Gerald Cox 2007-07-03 20:49:57 EDT
Thanks.  I tried the boot args, the only one which works is "noapic".
Comment 4 Gerald Cox 2007-07-03 20:51:13 EDT
Changing to F7.
Comment 5 Darlene J. Ford 2007-07-04 12:30:47 EDT
I'm embarrassed to admit that I didn't quite understand how to try the noapic 
bootarg workaround.  Do you have time to explain what you did?  

Thanks.
Comment 6 Gerald Cox 2007-07-04 19:05:08 EDT
Found a reference to option "pci=noacpi" tried and it appears to work much
better than using the "noapic" option.  The "noapic" option was causing problems
with my soundcard and tvtuner card.  I've only been running this way for six
hours but so far so good.  Your mileage may vary.  It appears the problem with
the motherboard is related to "acpi" and NOT "apic".  To make the change either
go into root mode or use sudo, then edit /boot/grub/grub.conf
go to the line which begins with "kernel", and add "pci=noacpi" (without quotes). 
My entries now appear as follows:

title Fedora (2.6.21-1.3228.fc7)
        root (hd0,0)
        kernel /vmlinuz-2.6.21-1.3228.fc7 ro root=LABEL=/ pci=noacpi rhgb quiet
        initrd /initrd-2.6.21-1.3228.fc7.img
title Fedora (2.6.21-1.3194.fc7)
        root (hd0,0)
        kernel /vmlinuz-2.6.21-1.3194.fc7 ro root=LABEL=/ pci=noacpi rhgb quiet
        initrd /initrd-2.6.21-1.3194.fc7.img


Comment 7 Cliff Schomburg 2007-08-18 11:57:55 EDT
I've have the same bug, 8254 timer not connected to IO-APIC, Kernel panic - not 
syncing.  I'm completely new to Linux, so if someone could spell out to me what 
exactly is going on with this I would really appreciate it.

I'm running an ASUS A8N-SLI Deluxe, nVidia nForce 4 chipset, AMD64, 1 GB RAM, 
nVidia 6800.  I'm going to try making the change that Gerald Cox suggested in 
the bottom post; I'll see how it goes.

Even if this works, I'd still like to know if any has a good idea as to why 
this happened.
Comment 8 Cliff Schomburg 2007-08-18 12:34:24 EDT
I made the change above by adding "pci=noacpi" and now I get all kinds of other 
errors.

Booting the kernel.

powernow-k8: MP systems not supported by PSB BIOS structure
powernow-k8: MP systems not supported by PSB BIOS structure
Red Hat nash version 6.0.9 starting
ohci_hcd 0000:00:02.0: Found HC with no IRQ.  Check BIOS/PCI 0000:00:02.0 setup!
ohci_hcd 0000:00:02.0: init 0000:00:02.0 fail, -19
ehci_hcd 0000:00:02.1: Found HC with no IRQ.  Check BIOS/PCI 0000:00:02.1 setup!
ehci_hcd 0000:00:02.1: init 0000:00:02.1 fail, -19
ata2.00: failed to set xfermode (err_mask=0x40)
ata2.00: failed to set xfermode (err_mask=0x40)
ata2.00: failed to set xfermode (err_mask=0x40)
sata_nv 0000:00:08.0: irq 27 request failed: -38
  Reading all physical volumes.  This may take a while...
  No volume groups found
  Volume group "VolGroup00" not found
Unable to access resume device (/dev/VolGroup00/LogVol01)
mount: could not find filesystem '/dev/root'
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init!

I'm wicked new at all this, but it looks to me like (1) it doens't like my 
hardware for some reason (it doesn't like my BIOS settings?) and (2) it is not 
finding my hard drive after (or while) it loads the kernel.

Any suggestions?
Comment 9 Gerald Cox 2007-08-18 13:02:10 EDT
Unfortuately this bug report is specific to the GA-M59SLI-S5 which has the
NVIDIA NFORCE 590 SLI chipset.  Also, these types of issues can be BIOS
specific.  I am kind of surprised your having so many problems since my thought
was the NFORCE 4 was fairly stable with Linux.  You've probably already done
this, but be sure to verify that you are running the latest recommended version
of the BIOS obtained from the Vendors website.  If you've done that, try booting
using the NOAPIC option.  If that doesn't work, I would create a bug report
specific to your motherboard and BIOS level.
Comment 10 Cliff Schomburg 2007-08-18 13:18:11 EDT
Thanks.  I have updated the BIOS; I'll give the NOAPIC option a try and see if 
that works.

Another strange thing is that I was runninng Ubuntu linux 6.x LTS the other day 
and had no problems with it.  I just tried to install Ubuntu 7.04 on my other 
hard drive and recieved the same "timer not connected to IO-APIC" error.

Anyways, I'll try that NOAPIC option and if that doesn't work, I'll submit a 
bug report.  Thanks for the help.
Comment 11 Cliff Schomburg 2007-08-18 14:51:25 EDT
The noapic option worked.  Thank you.  What have I disabled?  Will it decrease 
functionality?  Should I still list this as a new bug with my hardware?
Comment 12 Chuck Ebbert 2007-08-20 16:40:40 EDT
There are some other kernel options for the timer setup:

acpi_skip_timer_override
acpi_use_timer_override

enable_timer_pin_1
disable_timer_pin_1

Comment 13 Jack Deslippe 2007-08-28 16:42:20 EDT
I also use the noapic option to get my Gigabyte AM2 board working.  What does
noapic do?  Will this cause other problems?
Comment 14 Christopher Brown 2007-09-13 11:46:39 EDT
Hello Jack,

I'm reviewing this bug as part of the kernel bug triage project.

http://fedoraproject.org/wiki/KernelBugTriage

(In reply to comment #11)
> The noapic option worked.  Thank you.  What have I disabled?

You have disabled an controller which routes interrupts in a potentially more
efficient manner. Some implementations are defective and currently yours does
not seem to be working.

> Will it decrease functionality?

Yes but keep trying with successive kernels and fixes often find their way in.
Sometimes however it is simply a case of bad hardware. Do not be concerned - the
decrease is negligible IMO.

> Should I still list this as a new bug with my hardware?

Yes, although I am unsure where the best place is to put this. Probably to leave
this bug open until you can boot without the noapic switch.

Cheers
Chris
Comment 15 Gerald Cox 2007-09-13 16:51:24 EDT
This seems to be a well known problem which affects AM2 based motherboards. 
Here is a link to an article which describes:

http://www.linuxjournal.com/node/1000074

As mentioned above, when I used the: "noapic" parameter, I was able to boot,
however that parameter caused all sorts of collateral issues (I put them
bugzilla, do a search on GA-M59SLI-S5 to find).  I found that for the
GA-M59SLI-S5 at the F7 BIOS Level, the "pci=noacpi" works much better and for
me, the best workaround.

Since this problem is occurring with different motherboard manufacturers, I
would suspect it to be something related to the kernel and AM2/NVIDIA rather
than a particular implementation being the cause.  
Comment 16 Chuck Ebbert 2007-09-13 18:36:40 EDT
(In reply to comment #15)
> This seems to be a well known problem which affects AM2 based motherboards. 
> Here is a link to an article which describes:
> 
> http://www.linuxjournal.com/node/1000074
> 
> As mentioned above, when I used the: "noapic" parameter, I was able to boot,
> however that parameter caused all sorts of collateral issues (I put them
> bugzilla, do a search on GA-M59SLI-S5 to find).  I found that for the
> GA-M59SLI-S5 at the F7 BIOS Level, the "pci=noacpi" works much better and for
> me, the best workaround.
> 
> Since this problem is occurring with different motherboard manufacturers, I
> would suspect it to be something related to the kernel and AM2/NVIDIA rather
> than a particular implementation being the cause.  


Sometimes "nolapic" works better, too.
Comment 17 Gerald Cox 2007-09-13 23:40:34 EDT
Thanks for that info... I tried the nolapic and found it also worked.  

I did some additional searches and found that "acpi_use_timer_override" also
fixes the problem and apparently for this particular motherboard is the
workaround of choice and the only option needed.  Looks like the problem is because 
HPET (high precision event timer) support isn't correctly implemented in the BIOS.  

I also found where there is some work going on in to enable HPET support for
motherboards with a broken bios:
http://lkml.org/lkml/2007/4/20/374

Why so many different manufacturers have the same problem is curious - and looks
like it might point back to NVIDIA.  

In the meantime, in addition to changing to the above option, I've opened a bug
report with Gigabyte asking them to enable HPET support.  Looks like they have
already fixed on the GA-M57SLI-S4 BIOS.
Comment 18 Gerald Cox 2007-09-17 19:14:03 EDT
Gigabyte has provided a test BIOS "m59slis5.f8g" which appears to have fixed the
problem.  They should be posting on their website; or you can request it
directly from them via their website.  I am now able to boot without using the
"acpi_user_timer_override" parameter.  
Comment 19 Christopher Brown 2007-09-18 04:36:55 EDT
Okay, thanks for the info Gerald. I'm closing as it appears to be fixed for you
but please re-open if you feel this still merits some attention.

Cheers
Chris
Comment 20 Jack Deslippe 2007-09-19 20:18:16 EDT
Gerald, 

I don't see this up on their website anywhere - can you give me a link to the
page?  The official page just shows F7.  Is it still testing?  Flashing the bios
with a testing bios scares me a bit...
Comment 21 Gerald Cox 2007-09-19 21:15:38 EDT
Jack,

Yes, it is a test BIOS and according to Gigabyte, still in Beta.  I could send
to you but probably better that everyone who needs it send them a question
through their website and request - that way it may speed them up a bit to get
the final version posted.  Just ask for it by name, they are fairly quick and
you should receive the next business day.  The motherboard has a backup BIOS, so
before you flash just make sure the backup has the current version - that way,
you should be fine.  The BIOS comes with HPET enabled so you shouldn't need to
make any BIOS configuration changes, just flash and go...  ;-)  I've been
running for several days now, with no problem whatsoever... but remember, YMMV.
Comment 22 Jack Deslippe 2007-10-05 18:35:20 EDT
Gerald the Gigabyte page here:
http://www.gigabyte.com.tw/Support/Motherboard/BIOS_Model.aspx?ProductID=2302
shows a new bios F8H - have you tried this yet?  Does the fact that H comes
after G in the alphabet mean this is a stable bios with the fix?
Comment 23 Gerald Cox 2007-10-06 11:25:45 EDT
The F8H BIOS does not show up on the USA site, but I was curious, so gave it a
try.  IT DOES NOT WORK.  You need to contact support and request the F8G BIOS. 
The HPET options will then show under POWER MANAGEMENT, after pressing CTRL +
F1.  HPET options are not available under the F8H BIOS.
Comment 24 Jack Deslippe 2007-10-07 02:47:11 EDT
Hey Gerald, I got the f8g bios from gigabyte.  How do I flash my bios without a
floppy drive??? I actually bought a cheap floppy drive, but can't get it to work
for the life of me...  Can I do this with a cdrom??  Sorry for the basic question.
Comment 25 Gerald Cox 2007-10-07 12:51:25 EDT
Not to my knowledge.  You either use the onboard flashing function which
requires a floppy or you flash from within the Microsoft Windows OS using the
Gigabyte utility.  You might ask Gigabyte on their support page if they have any
other suggestions.
Comment 26 Jack Deslippe 2007-10-07 22:06:39 EDT
Ok, I figured out how to flash from a thumb drive.  It seems to be working.  I
got rid of the noapic option and it seems to be all good. Thanks for all your
efforts!

Note You need to log in before you can comment on or make changes to this bug.