Bug 235820 - "Not on the same filesystem" when moving files graphically between two nfs mounts and from nfs to disk
"Not on the same filesystem" when moving files graphically between two nfs mo...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-10 07:45 EDT by Aleix Solé
Modified: 2015-03-03 17:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 15:29:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleix Solé 2007-04-10 07:45:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.11) Gecko/20070327 Ubuntu/dapper-security Firefox/1.5.0.11

Description of problem:
In a computer with two nfs filesystems mounted, the "Not on the same filesystem" error appears when:

1) Trying to drag and drop a file between the shares

2) Trying to delete a file on one of the shares


On nautilus 2.14 with libgail17 (ie Fedora Core 5) this was working perfectly. Seems to be a nautilus (or underlying libs?) problem.


Other causes have been discarded:

- Files can be moved using drag and drop between two konqueror browsers
 
- Files can be moved using the console


nautilus-2.18.0.1-2 rpm from fc7 has also been tried, replacing 2.16 via rpm --erase and rpm -i, but doesn't fix the problem.

Version-Release number of selected component (if applicable):
nautilus-2.16.2-7, nautilus-2.18.0.1-2 with libgail-gnome-1.1.3-1.2.1

How reproducible:
Always


Steps to Reproduce:
1.Mount two NFS shares with rw permissions with some test files
2.Navigate them graphically using two nautilus windows
3. Move a file from one of the windows to the other one => nautilus pops out an error box
4. Try to delete a file from one of the windows => same error box (moving to .Trash?)


Actual Results:
"Not on same filesystem" error popup

Expected Results:
Files should be moved correctly between the two mounted NFS shares.

Additional info:
Comment 1 Bug Zapper 2008-04-04 02:49:43 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 2 Bug Zapper 2008-05-06 15:29:39 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.