Bug 235866 - RFE: remove gnome-user-share from LiveCD build
Summary: RFE: remove gnome-user-share from LiveCD build
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Bill Nottingham
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: Fedora7LiveCD
TreeView+ depends on / blocked
 
Reported: 2007-04-10 15:39 UTC by Joe Orton
Modified: 2014-03-17 03:06 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-10 19:50:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Orton 2007-04-10 15:39:15 UTC
Description of problem:
Matthew Miller points out that gnome-user-share is on the Live CD - this package
will pull in the entire httpd deps chain (apr, apr-util, openldap, ...) which is
inevitably going to eat lots of bits.

I'd suggest if bits on the CD are at a premium this is dropped from the Live CD
build - any dissenters?  Matthias, is this OK with you?

Comment 1 Matthias Clasen 2007-04-10 16:05:02 UTC
Yes, I'm dissenting. 

I've already moved the bug that Matthew filed yesterday to httpd as a request
for more modular packaging. Not sure if that is going to help much, or if the
httpd binary already pulls in all the deps.

Of course, if there is no room, then gnome-user-share has to go.

Comment 2 Matthias Clasen 2007-04-10 16:06:46 UTC
Oh, also, it is a bit tough to call a request to remove a package RFE. 
How about RFD - request for degrading ? 
And I don't know how removing features interacts with a feature freeze.

Comment 3 Matthew Miller 2007-04-10 16:12:13 UTC
The other bug is bug #235682, by the way. I think that approach is preferable
because the LiveCD is only one case where this is desirable.

Comment 4 Jeremy Katz 2007-04-10 19:50:28 UTC
gnome-user-share isn't the cause of our space concerns and if we're installing
it by default in the "normal" case, it should also be there for the live image.


Note You need to log in before you can comment on or make changes to this bug.