Bug 235890 - 3.0.24-4 breaks network share access
Summary: 3.0.24-4 breaks network share access
Status: CLOSED DUPLICATE of bug 235821
Alias: None
Product: Fedora
Classification: Fedora
Component: samba   
(Show other bugs)
Version: 5
Hardware: x86_64 Linux
medium
high
Target Milestone: ---
Assignee: Samba Maint Team
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-10 17:25 UTC by Calvin Dodge
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-10 17:42:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Calvin Dodge 2007-04-10 17:25:17 UTC
Description of problem: After Samba was upgraded this morning (4/10/2007), the
Windows computers (primarily XP SP2) could not access most network shares
(common or home)


Version-Release number of selected component (if applicable): 3.0.24-4


How reproducible: Unknown - have only one system running Core 5, and can't waste
customer's time monkeying with reinstalls. Downgrading to 3.0.24-3 fixed the
problem.


Steps to Reproduce:
1. Update to 3.0.24-4
2. Try accessing network shares
3.
  
Actual results: can't reach network shares


Expected results: should be able to reach network shares

Additional info: Strangely, 1 folder in 1 share _could_ be accessed, but files
inside folder not visible. Folder ownership and permissions are identical to
other folders in share. Selinux is disabled (and has been for some time due to
conflict with Samba), so is assumed to not be the problem.

Other updates this morning were popt, libattr and libacl

Comment 1 Simo Sorce 2007-04-10 17:42:27 UTC
Sorry but this is a known issue. We had to change a bad default set upstream in
3.0.24
The easy fix is to just restart your windows client.
Otherwise if you can't restart the clients you can set root msfds = yes in
smb.conf and restart samba.
But this may have other subtle consequences that's why we changed the default
back to root msdfs = no

*** This bug has been marked as a duplicate of 235821 ***


Note You need to log in before you can comment on or make changes to this bug.