Bug 235898 - MAC address zeroed on reboot of rx2600
MAC address zeroed on reboot of rx2600
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivan Vecera
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-10 14:00 EDT by Flavio Leitner
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-29 04:16:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch for RHEL5 (502 bytes, patch)
2007-04-10 14:00 EDT, Flavio Leitner
no flags Details | Diff

  None (edit)
Description Flavio Leitner 2007-04-10 14:00:00 EDT
On a rx2600 machine, after a reboot, the EFI shows the MAC address as 'zero'.
Power on/off of the node will bring the state back to normal.

Here is a snapshot of the problem:

After power off/power on:
     NO VOLUME LABEL [Acpi(HWP0002,100)/Pci(1|0)/Scsi(Pun0,Lun0)/HD(P
     Removable Media Boot [Acpi(HWP0002,0)/Pci(2|0)/Ata(Primary,Maste
     Load File [EFI Shell [Built-in]]
     Load File [Acpi(HWP0002,0)/Pci(3|0)/Mac(00306E4A7352)]
  -->Load File [Acpi(HWP0002,100)/Pci(2|0)/Mac(00306E4A7226)]
     Load File [Acpi(HWP0002,600)/Pci(1|0)/Mac(00306E4BA706)]
     Exit
 
After performing a "reboot" from :
     NO VOLUME LABEL [Acpi(HWP0002,100)/Pci(1|0)/Scsi(Pun0,Lun0)/HD(P
     Removable Media Boot [Acpi(HWP0002,0)/Pci(2|0)/Ata(Primary,Maste
     Load File [EFI Shell [Built-in]]
     Load File [Acpi(HWP0002,0)/Pci(3|0)/Mac(00306E4A7352)]
  -->Load File [Acpi(HWP0002,100)/Pci(2|0)/Mac(000000000000)]
     Load File [Acpi(HWP0002,600)/Pci(1|0)/Mac(00306E4BA706)]
     Exit

This problem is seen in RHEL4U4 which is kernel-2.6.9-42. The previous kernel
kernel-2.6.9-34 did not have this problem. The broadcom tg3 driver had changed
from 34 kernel to 42 kernel. 

Two patches had changed from 34 kernel to 42 kernel. The are

--- linux-2.6.9-net-tg3-ethtool.patch and linux-2.6.9-net-tg3-update.patch

The linux-2.6.9-net-tg3-ethtool.patch was the one that had introduced the
problem in the tg3 driver. The problem was traced down to the function call 

tg3_set_power_state(tp, PCI_D3hot); 

in tg3_close() in the tg3.c file. When this was commented and the module built
again, the MAC was visible.
Comment 1 Flavio Leitner 2007-04-10 14:00:00 EDT
Created attachment 152165 [details]
Patch for RHEL5
Comment 2 Andy Gospodarek 2007-08-28 10:35:48 EDT
Does this patch break WOL support?
Comment 3 Ivan Vecera 2007-09-10 05:58:43 EDT
Hi, I contacted Michael Chan (tg3 maintainer) and he confirmed my divination
that the removal of the problematic line will break WoL support. Michael did
some investigation and found that the problem is caused by EFI driver and the
new version of it should fix this problem.
Could you please provide me the version of EFI driver used on the RX2600 system?

-- Ivan
Comment 4 Andy Gospodarek 2007-11-06 11:29:23 EST
If this is an EFI driver problem, then we should close it as NOTABUG.
Comment 5 Ivan Vecera 2007-11-06 11:43:59 EST
The 235894 request same thing but for RHEL4. Michael Chan thinks that the
problem is in EFI driver, but he requested additional information (EFI driver
version & boot code firmware version - see 235894). I didn't receive any
response so I'm still waiting.
Comment 6 Ivan Vecera 2007-11-29 04:16:54 EST
According BZ235894 (the same issue but for RHEL4) this is not a problem of the
tg3 driver but of the EFI driver (Doug Chapman was unable to reproduce this bug
on his rx2600 with tg3 - EFI driver v3.0.7). So now I'm closing this issue as
NOTABUG. 

Note You need to log in before you can comment on or make changes to this bug.