Bug 235902 - [SIS PATA SLAVE]: Live CD does not start from IDE cd drive
[SIS PATA SLAVE]: Live CD does not start from IDE cd drive
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alan Cox
Brian Brock
: Reopened
Depends On:
Blocks: FC7Blocker Fedora7LiveCD
  Show dependency treegraph
 
Reported: 2007-04-10 14:14 EDT by Richard Hally
Modified: 2013-01-09 23:15 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-07 14:08:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg from system where CD is missing. (current rawhide) (23.39 KB, application/octet-stream)
2007-04-12 13:29 EDT, Richard Hally
no flags Details
Output of "lspci" (805 bytes, text/plain)
2007-04-17 16:42 EDT, Peter van Egdom
no flags Details
Output of "dmesg" (14.45 KB, text/plain)
2007-04-17 16:44 EDT, Peter van Egdom
no flags Details
Output from the kernel (2.19 KB, text/plain)
2007-04-18 19:40 EDT, Patrick Hoffmann
no flags Details
Output from lspci (13.34 KB, text/plain)
2007-04-18 19:41 EDT, Patrick Hoffmann
no flags Details
Output from dmesg running from debian etch (11.97 KB, text/plain)
2007-04-18 19:43 EDT, Patrick Hoffmann
no flags Details
Output from hdparm (2.55 KB, text/plain)
2007-04-18 19:45 EDT, Patrick Hoffmann
no flags Details
Bug fix (I hope) (1.10 KB, patch)
2007-04-19 06:03 EDT, Alan Cox
no flags Details | Diff
syslog file from F7 dev. tree of 2007.04.19 with the call trace. (18.50 KB, text/plain)
2007-04-19 16:37 EDT, Peter van Egdom
no flags Details
output of "lspci -v" from F7 dev. tree of 2007.04.19 (3.16 KB, text/plain)
2007-04-19 16:39 EDT, Peter van Egdom
no flags Details
dmesg from current rawhide that shows the same problem with IDE CD drive (25.54 KB, text/plain)
2007-05-12 18:47 EDT, Richard Hally
no flags Details
/var/log/dmesg from FC5 on Acer TM612TX (17.05 KB, text/plain)
2007-05-13 05:12 EDT, Elio Tondo
no flags Details
Screenshot on Acer TM612TX (219.74 KB, image/jpeg)
2007-06-02 08:43 EDT, Elio Tondo
no flags Details
dmesg from booting 3228 kernel (22.49 KB, text/plain)
2007-06-19 12:41 EDT, Richard Hally
no flags Details

  None (edit)
Description Richard Hally 2007-04-10 14:14:54 EDT
Description of problem:
When trying to boot the F7 test 3 Live CD I get a message 
"Warning: Cannot find root file system. Create symlink for /dev/root"
and I get a shell prompt.
there is no entry for the CD drive in /dev


Version-Release number of selected component (if applicable):


How reproducible:
every time

Steps to Reproduce:
1. insert Live CD in cd drive 
2. boot
3.
  
Actual results:
Message warning cannot find root file system

Expected results:
Live cd to boot up.

Additional info:
This system uses IDE hard drives and CD_RW drive.
The current rawhide kernels do not see the CD drive either.
This system uses the SiS chip set and pata_sis.
Comment 1 Jeremy Katz 2007-04-11 17:46:57 EDT
Can you provide the output of lspci as well as a dmesg from a running system
where the CD drive isn't being found?
Comment 2 Richard Hally 2007-04-12 13:25:22 EDT
here is the lspci: (dmesg attachment to follow)
[root@localhost ~]# lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 661FX/M661FX/M661MX Host
(rev 11)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual
PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS963 [MuTIOL Media IO]
(rev 25)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97
Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760
PCI/AGP or 662/761Gx PCIE VGA Display Adapter
[root@localhost ~]# 
Comment 3 Richard Hally 2007-04-12 13:29:37 EDT
Created attachment 152487 [details]
dmesg from system where CD is missing. (current rawhide)
Comment 4 Peter van Egdom 2007-04-17 16:39:28 EDT
My system (also with IDE hard drives, a DVD-RW drive and a SiS IDE interface)
has also got this problem with the Fedora 7 test 3 Live CD. Before it gives the
'cannot find root file system' warning it generates a kernel panic after probing
[pata_sis]. This error also occurs with Fedora 7 test 1 and Fedora 7 test 2.

As mentioned in the "F7T4 and SATA/IDE testing - a call to arms!" posting
("https://www.redhat.com/archives/fedora-test-list/2007-April/msg00289.html") on
the fedora-test mailing-list, I'll attach "dmesg.txt" and "lspci.txt" generated
on my system to this bugzilla report.

ps. I also tried the current (17 april 2007) Fedora Development snapshot of
"boot.iso" with an FTP-install. This also gives a kernel panic after probing
[pata_sis]. It does get to the partioning screen but Anaconda doesn't find any
hard drives to install to.
Comment 5 Peter van Egdom 2007-04-17 16:42:32 EDT
Created attachment 152852 [details]
Output of "lspci"
Comment 6 Peter van Egdom 2007-04-17 16:44:10 EDT
Created attachment 152853 [details]
Output of "dmesg"
Comment 7 Alan Cox 2007-04-17 18:26:25 EDT
I need the info from the kernel panic, even if you have to attach it as a jpeg
from a digital camera 8)
Comment 8 Patrick Hoffmann 2007-04-18 19:38:19 EDT
I have the same problem with the latest development boot.iso.
Comment 9 Patrick Hoffmann 2007-04-18 19:40:16 EDT
Created attachment 152966 [details]
Output from the kernel
Comment 10 Patrick Hoffmann 2007-04-18 19:41:43 EDT
Created attachment 152967 [details]
Output from lspci
Comment 11 Patrick Hoffmann 2007-04-18 19:43:02 EDT
Created attachment 152968 [details]
Output from dmesg running from debian etch
Comment 12 Patrick Hoffmann 2007-04-18 19:45:42 EDT
Created attachment 152969 [details]
Output from hdparm
Comment 13 Alan Cox 2007-04-19 05:56:58 EDT
Thanks. Bug identified I think just working on a fix
Comment 14 Alan Cox 2007-04-19 06:03:17 EDT
Created attachment 152986 [details]
Bug fix (I hope)
Comment 15 Patrick Hoffmann 2007-04-19 14:24:58 EDT
The patch fixed it. Thanks.
Comment 16 Peter van Egdom 2007-04-19 16:37:45 EDT
Created attachment 153056 [details]
syslog file from F7 dev. tree of 2007.04.19 with the call trace.
Comment 17 Peter van Egdom 2007-04-19 16:39:34 EDT
Created attachment 153057 [details]
output of "lspci -v" from F7 dev. tree of 2007.04.19
Comment 18 Peter van Egdom 2007-04-20 18:52:03 EDT
Today I tried the Fedora Development "boot.iso" snapshot of 2007.04.21. This
time the [pata_sis] module loaded correctly, without any kernel oops. Anaconda
did also find my hard drive this time. The patch in "kernel-2.6.20-1.3094.fc7"
seems to have fixed this problem. Thanks for the patch...
Comment 19 Jeremy Katz 2007-04-20 21:26:16 EDT
Great... thanks for the confirmation!
Comment 20 Richard Hally 2007-04-21 00:47:01 EDT
The original problem reported on this bug still exists with the
rawhide-20070419.1-i386-live.iso.
The dmesg and lspci output look the same with the kernel-2.6.20-1.3094.fc7 from
todays rawhide.
The patch may have fixed the oops but not the original problem.
bug reopened.
Comment 21 Adam Pribyl 2007-04-22 04:34:46 EDT
(In reply to comment #20)

Peter van Egdom reported that 20070421 is fixed, you are using 20070419, so you
should probably try newer version.

Comment 22 Richard Hally 2007-04-27 01:02:48 EDT
With the Test 4 Live CD (F-6.93-i386-Live.iso) the failure occurs sooner in the
boot sequence.
 After selecting "Run from image" (or any of the other options) from the initial
menu, all I get is:
"loading vmlinuz..................isolinux: Disk error 80, AX=4200, drive 9F
Boot failed: press a key to retry..." 

Please let me know if there is any other information I can provide.
Btw, booting an old 2.6.18 kernel shows that the hardware is working
-
class: CDROM
bus: IDE
detached: 0
device: hdd
desc: "SAMSUNG CD-R/RW SW-252S"
-
Comment 23 Mike Chambers 2007-05-06 20:28:37 EDT
A day or two within FC7T4 coming out, I did a rawhide install, and I too have
the SiS MB, or MSI 7060 is what it's called.  Here is my lspci output in case it
helps.

[root@scrappy ~]# lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 661FX/M661FX/M661MX Host
(rev 11)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual
PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS964 [MuTIOL Media IO]
(rev 36)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97
Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast
Ethernet (rev 90)
00:06.0 Multimedia audio controller: Creative Labs SB Audigy LS
00:08.0 Communication controller: Conexant HSF 56k HSFi Modem (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc RV516 [Radeon
X1300/X1550 Series]
01:00.1 Display controller: ATI Technologies Inc RV516 [Radeon X1300 Pro]
(Secondary)

I have *NOT* tried a Live CD though, so I can if need be if can help.  But I am
current with rawhide (up until the merge anyway) and everyone works.  Although I
have seen the pata_sis module being mentioned, and I don't have any pata drives
if that matters, just IDE.
Comment 24 Will Woods 2007-05-07 13:47:41 EDT
Re: comment #23:
> I don't have any pata drives if that matters, just IDE.

PATA and IDE are two names for the same thing.

Re: comment #22: 

> isolinux: Disk error 80, AX=4200, drive 9F

That's probably a bad CD burn. Try burning the CD again, preferably on some
different media. Actually, can you try using the latest LiveCD from
http://torrent.fedoraproject.org/ - that should definitely have the patch needed.
Comment 25 Elio Tondo 2007-05-08 07:26:56 EDT
Same problem here, on an old Acer TravelMate 612TX (Pentium III 900, 512 MB RAM,
HDD 40 GB IDE, CD-ROM IDE, i815 chipset). When booting the LiveCD, the kernel
starts but then the IDE CD recognized with 1 sector of 512 bytes (!), and
(obviously) the root FS is not mounted, and after some IDE errors and retries a
shell prompt appears.
This happened since F7test1; up to test3 I used to have problems also on other
"old" hardware (e.g. a desktop PIII probably with a VIA chipset) but now test4
boots with no problem on that hardware; however it still fails on the laptop.

I had no problem so far with FC3 to FC6 on the same laptop; if this can be
useful, I can boot the intalled FC6 and send you the output of lspci and/or
dmesg from that version; I also can send a picture of the laptop screen; anyway
the important part seems:

sdb: sector size 0 reported, assuming 512
SCSI device sdb: 1 512-byte hdwr sectors (0 MB)
sdb: Write Protect is off
sdb: Mode Sense: 00 00 00 00
sdb: cache data unavailable
(the above lines repeated another time, then:)
sdb: assuming drive cache: write through
sdb:<3>ata2.00: exception Emask
ata2.00: cmd a0/01:00:00:....
         res 40/00:03:00:....

I am available to test a modified LiveCD if this can be useful.

Elio
Comment 26 Mike Chambers 2007-05-09 08:32:25 EDT
(In reply to comment #23)
> A day or two within FC7T4 coming out, I did a rawhide install, and I too have
> the SiS MB, or MSI 7060 is what it's called.  Here is my lspci output in case it
> helps.
> 
> [root@scrappy ~]# lspci
> 00:00.0 Host bridge: Silicon Integrated Systems [SiS] 661FX/M661FX/M661MX Host
> (rev 11)
> 00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual
> PCI-to-PCI bridge)
> 00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS964 [MuTIOL Media IO]
> (rev 36)
> 00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
> 00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97
> Sound Controller (rev a0)
> 00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller
(rev 0f)
> 00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller
(rev 0f)
> 00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller
(rev 0f)
> 00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
> 00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast
> Ethernet (rev 90)
> 00:06.0 Multimedia audio controller: Creative Labs SB Audigy LS
> 00:08.0 Communication controller: Conexant HSF 56k HSFi Modem (rev 01)
> 01:00.0 VGA compatible controller: ATI Technologies Inc RV516 [Radeon
> X1300/X1550 Series]
> 01:00.1 Display controller: ATI Technologies Inc RV516 [Radeon X1300 Pro]
> (Secondary)
> 
> I have *NOT* tried a Live CD though, so I can if need be if can help.  But I am
> current with rawhide (up until the merge anyway) and everyone works.  Although I
> have seen the pata_sis module being mentioned, and I don't have any pata drives
> if that matters, just IDE.

I downloaded and booted with the 5/02 Live CD and it booted fine, although was
very slow and thought there was way too many services trying to start for a live
cd lookat-only.  The only thing it did, was while firefox was open, I configured
my network, and when it went to an online page, it froze and had to hit reset
button.  But the cdrom booted up with my info above.
Comment 27 Richard Hally 2007-05-12 18:34:51 EDT
re: comment 24 disk error;
I burned another copy of the bittorrent rawhide-20070502-i386-Live.iso and it
produces the original error.
"warning: Cannot find root file system!
create symlink dev root etc...

The output on the screen as it is booting the kernel looks like the attached
dmesg  up to the point where it ends the retries on ata2.01. At that point it
produces the error about not finding dev root.
Comment 28 Richard Hally 2007-05-12 18:47:47 EDT
Created attachment 154592 [details]
dmesg from current rawhide that shows the same problem with IDE CD drive
Comment 29 Elio Tondo 2007-05-13 05:12:54 EDT
Created attachment 154608 [details]
/var/log/dmesg from FC5 on Acer TM612TX
Comment 30 Elio Tondo 2007-05-13 05:14:17 EDT
Here is the FC5 lspci output on my Acer TM612TX:

00:00.0 Host bridge: Intel Corporation 82815 815 Chipset Host Bridge and Memory
Controller Hub (rev 11)
00:02.0 VGA compatible controller: Intel Corporation 82815 CGC [Chipset Graphics
Controller] (rev 11)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 03)
00:1f.0 ISA bridge: Intel Corporation 82801BAM ISA Bridge (LPC) (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801BAM IDE U100 (rev 03)
00:1f.2 USB Controller: Intel Corporation 82801BA/BAM USB (Hub #1) (rev 03)
00:1f.3 SMBus: Intel Corporation 82801BA/BAM SMBus (rev 03)
00:1f.4 USB Controller: Intel Corporation 82801BA/BAM USB (Hub #2) (rev 03)
00:1f.5 Multimedia audio controller: Intel Corporation 82801BA/BAM AC'97 Audio
(rev 03)
00:1f.6 Modem: Intel Corporation 82801BA/BAM AC'97 Modem (rev 03)
01:08.0 Ethernet controller: Intel Corporation 82801BA/BAM/CA/CAM Ethernet
Controller (rev 03)
01:0f.0 CardBus bridge: O2 Micro, Inc. OZ6933/711E1 CardBus/SmartCardBus
Controller (rev 02)
01:0f.1 CardBus bridge: O2 Micro, Inc. OZ6933/711E1 CardBus/SmartCardBus
Controller (rev 02)
02:00.0 USB Controller: NEC Corporation USB (rev 43)
02:00.1 USB Controller: NEC Corporation USB (rev 43)
02:00.2 USB Controller: NEC Corporation USB 2.0 (rev 04)

Please ignore the last three lines, they are related to a D-Link PC card with
two additional USB ports.

In the message above I sent as an attachment the content of dmesg from the same
FC5 working installation.

Elio
Comment 31 Elio Tondo 2007-06-02 08:43:30 EDT
Created attachment 155980 [details]
Screenshot on Acer TM612TX

I tried the Fedora 7 KDE Live CD (final version) and it still doesn't work on
my laptop. You can see the screenshot; it keeps repeating the last lines.

Are there any plans to fix this problem?

Elio
Comment 32 Alan Cox 2007-06-04 05:45:12 EDT
Elio: your bug is different to the other problems in this bug entry. We do plan
to fix  the problem with one or two CD drives having trouble after SRST but it
will take time and the work will be done upstream initially.
Comment 33 Elio Tondo 2007-06-04 05:57:11 EDT
Thank you, Alan. If I can help testing "should-be-fixed" versions on my laptop
(assuming that it survives...) please let me know.

On a (totally urelated and off-topic here, but I don't know where to ask): I am
requesting the inclusion of MySQL support in the standard Fedora RPM since
2006-03-15, with no success; this is the Bugzilla reference:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=185515 . Are there any
other ways to ask for a simple feature addition like this one?

Thanks, Elio
Comment 34 Richard Hally 2007-06-11 16:59:58 EDT
What are the prospects for getting this fixed?
Should I file a separate bug against the kernel since I can not use my CD-RW
drive at all?
Comment 35 Alan Cox 2007-06-12 10:02:05 EDT
Two SiS fixes have gone upstream for the next kernel. A fix has also gone
upstream for some of the more recalcitrant CD devices. Whether that fixes a
specific case is hard to guess in advance
Comment 36 Jeremy Katz 2007-06-12 10:32:49 EDT
(In reply to comment #35)
> Two SiS fixes have gone upstream for the next kernel. A fix has also gone
> upstream for some of the more recalcitrant CD devices. Whether that fixes a
> specific case is hard to guess in advance

Which -rc are they in?  I was going to try to put up a new set of rawhide live
images this week anyway and can try to make sure to coordinate with davej to
ensure there's a new enough kernel for seeing if that helps Richard out.
Comment 37 Alan Cox 2007-06-12 13:15:12 EDT
git head at the moment. We should be pretty close to 2.6.22 final anyway
Comment 38 Alan Cox 2007-06-18 10:20:17 EDT
Everything relevant should be in -rc5 from a quick inspection. There is some
more stuff in 2.6.22-rc4-mm but that shouldn't be related.
Comment 39 Jeremy Katz 2007-06-18 10:40:10 EDT
Great.  -rc5 is in rawhide; I'll try to get a live CD fitting with it today (we
were slightly over last week, *sigh*) and put it out for people to try
Comment 40 Richard Hally 2007-06-19 12:41:42 EDT
Created attachment 157394 [details]
dmesg from booting 3228 kernel

the 3228 kernel is still not seeing the CD drive
Comment 41 Richard Hally 2007-09-07 14:08:39 EDT
You may as well close this bug since the CD drive is at least being recognized.
I'll open another bug about how it takes approx. 2:45 minutes to actually load
the driver and then other similarly long times to progress through the rest of
the boot process.
Thanks for your work,
Richard 

Note You need to log in before you can comment on or make changes to this bug.