Bug 235912 - (CVE-2007-1897) CVE-2007-1893, CVE-2007-1897: wordpress < 2.1.3 issues
CVE-2007-1893, CVE-2007-1897: wordpress < 2.1.3 issues
Product: Fedora
Classification: Fedora
Component: wordpress (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Berninger
Fedora Extras Quality Assurance
: Security
Depends On:
  Show dependency treegraph
Reported: 2007-04-10 14:57 EDT by Ville Skyttä
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-04-16 11:22:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2007-04-10 14:57:27 EDT
"WordPress 2.1.2, and probably earlier, allows remote authenticated users with
the contributor role to bypass intended access restrictions and invoke the
publish_posts functionality, which can be used to "publish a previously saved

"SQL injection vulnerability in xmlrpc.php in WordPress 2.1.2, and probably
earlier, allows remote authenticated users to execute arbitrary SQL commands via
a string parameter value in an XML RPC mt.setPostCategories method call, related
to the post_id variable."

All active FE releases have 2.1.3-RC2 which seems affected.  2.1.3 final is said
to fix these issues.
Comment 1 John Berninger 2007-04-16 11:22:34 EDT
New packages built (2.1.3 final)

Note You need to log in before you can comment on or make changes to this bug.