Bug 235927 - authconfig --enablenis --nisdomain=domain does not work
authconfig --enablenis --nisdomain=domain does not work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-10 16:39 EDT by Orion Poplawski
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-22 16:05:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2007-04-10 16:39:41 EDT
Description of problem:

Have:

authconfig --enableshadow --enablenis --nisdomain=yp.colorado-research.com

in my kickstart file.  After install NISDOMAIN was not set in
/etc/sysconfig/network.

After install ran:

# authconfig --enableshadow --enablenis --nisdomain=yp.colorado-research.com
--update

and it started ypbind and connected, but NISDOMAIN was still not set in
/etc/sysconfig/network.  On reboot, NIS did not start because the domain name
was not set.

 
Version-Release number of selected component (if applicable):
authconfig-5.3.13-3.fc7
Comment 1 Tomas Mraz 2007-04-11 03:47:28 EDT
What do you have in /etc/yp.conf after the kickstart and after the second
authconfig run?
Comment 2 Orion Poplawski 2007-04-11 11:10:43 EDT
# Valid entries are
#
# domain NISDOMAIN server HOSTNAME
#       Use server HOSTNAME for the domain NISDOMAIN.
#
# domain NISDOMAIN broadcast
#       Use  broadcast  on  the local net for domain NISDOMAIN
#
# domain NISDOMAIN slp
#       Query local SLP server for ypserver supporting NISDOMAIN
#
# ypserver HOSTNAME
#       Use server HOSTNAME for the  local  domain.  The
#       IP-address of server must be listed in /etc/hosts.
#
# broadcast
#       If no server for the default domain is specified or
#       none of them is rechable, try a broadcast call to
#       find a server.
#
domain yp.colorado-research.com broadcast
Comment 3 Tomas Mraz 2007-04-11 12:19:04 EDT
Could you try to remove the last line and rerun the authconfig with --update and
look at the yp.conf and sysconfig/network again?
Comment 4 Orion Poplawski 2007-04-11 12:49:53 EDT
That did it.  NISDOMAIN is set in sysconfig/network and yp.conf is correct.  So
now we just need to know what failed during install?
Comment 5 Tomas Mraz 2007-04-11 13:02:36 EDT
Well the kickstart command above is missing --update but that would mean that
neither yp.conf nor sysconfig/network will be set.

So I suppose --update was there. What's strange is why the sysconfig/network
wasn't set up correctly. Perhaps something overwrites it after authconfig was
run in kickstart? It would be really interesting to know what went wrong.

Nevertheless I have a fix for the second authconfig --update run so it will set
the sysconfig/network NISDOMAIN correctly even in the case it is already set in
yp.conf.
Comment 6 Orion Poplawski 2007-05-22 16:05:27 EDT
Apparently this was a problem with my local modification to the ypbind startup
script.  New ypbind init script can set the domain name based on /etc/yp.conf
and doesn't require NISDOMAINNAME set in /etc/sysconfig/network.  Sorry about that.

Note You need to log in before you can comment on or make changes to this bug.