Bug 235958 - Error 28 after RAM upgrade
Error 28 after RAM upgrade
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-10 22:32 EDT by Jesse Barnes
Modified: 2008-04-03 20:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 20:11:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Barnes 2007-04-10 22:32:02 EDT
I recently upgraded my motherboard to 3G of RAM (Intel DG965OT with Core 2 duo 
running FC6 x86_64 + some devel stuff) and grub started complaining 
about "Error 28:  Selected item cannot fit into memory" when I tried to boot 
Linux.  However:
  - windows boots fine
  - linux boots if I pass "mem=1G" on the command line
  - linux boots if I tell grub "uppermem 262144" before loading the kernel and 
initrd

After looking into it a little, it seems grub is confused about loading the 
initrd.  It states that it has 572k of low memory, and 3101876k of upper 
memory, so far so good (no signed vs. unsigned long or anything).  Then it 
tells me it will load the initrd:
  Linux-initrd @ 0xbd318000, 0x3043d8 bytes

This should be fine, since my memory map says I have memory from 
0x100000-0xbd62d000, and 0xbd318000 + 0x3043d8 = 0xbd61c3d8, so the initrd 
should have room.  But at this point, instead of happily booting, grub gives 
me the "Error 28" message above.  I looked at the grub sources a little to see 
if I could figure out what was going on, but my eyes started to bleed and I 
couldn't even make it give me a printf, so I figured I'd file a bug instead in 
the hope that someone else has navigated grub enough to spot what's probably a 
trivial error.

Thanks,
Jesse
Comment 1 Bug Zapper 2008-04-03 20:01:59 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 2 Jesse Barnes 2008-04-03 20:11:26 EDT
Just installed F8 + updates and I no longer see this problem.

Note You need to log in before you can comment on or make changes to this bug.