This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 235967 - Aptana Plugin freezes on ftp upload
Aptana Plugin freezes on ftp upload
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-11 00:41 EDT by Kamisamanou Burgess
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-07 02:50:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Aptana Log (562.31 KB, text/plain)
2007-04-11 00:41 EDT, Kamisamanou Burgess
no flags Details

  None (edit)
Description Kamisamanou Burgess 2007-04-11 00:41:09 EDT
Description of problem: In Fedora 6, Fedora Eclipse, with the Aptana plugin:
Upon creating an FTP connection, (Aptana, F. Eclipse, Java(FSF)) freezes,
consuming all system resources, and failing to respond.


Version-Release number of selected component (if applicable): 3.2.0 Build Id:
M20070212-1330 (Fedora Core release 6 (Zod))



How reproducible: Happens every time.


Steps to Reproduce:
1. Open Aptana under Fedora Eclipse
2. Click Add Site Connection in the Sync Manager
3. Under remote: Add new FTP...
4. Fill in necessary information and click Ok
  
Actual results:
(Aptana, F. Eclipse, Java(FSF)) Freezes, failing to respond, consuming all
resources.

Expected results:
Aptana connects successfully with the specified server.


Additional info:
Comment 1 Kamisamanou Burgess 2007-04-11 00:41:10 EDT
Created attachment 152197 [details]
Aptana Log
Comment 2 Ben Konrath 2007-04-11 01:36:44 EDT
I took a quick look at the log files and noticed this NPE a couple of time:

!ENTRY com.aptana.ide.editors 1 0 2007-04-11 00:35:24.916
!MESSAGE (Build 0.2.8.13889) Error occurred when firing changed event
!STACK 0
java.lang.NullPointerException
   at
com.aptana.ide.editors.unified.errors.UnifiedErrorManager.parseForErrors(UnifiedErrorManager.java:160)
   at
com.aptana.ide.editor.html.HTMLErrorManager.parseForErrors(HTMLErrorManager.java:68)
   at
com.aptana.ide.editors.unified.errors.UnifiedErrorManager.onContentChanged(UnifiedErrorManager.java:98)
   at
com.aptana.ide.editors.unified.FileService.fireContentChangedEvent(FileService.java:613)
   at
com.aptana.ide.editors.unified.FileService.fireLongDelayedContentChangedEvent(FileService.java:596)
   at
com.aptana.ide.editors.unified.LongIdleFileChangedNotifier.fireContentChangedEvent(LongIdleFileChangedNotifier.java:46)
   at
com.aptana.ide.editors.unified.IdleFileChangedNotifier.onUpdaterThreadUpdate(IdleFileChangedNotifier.java:73)
   at com.aptana.ide.editors.unified.utils.UpdaterThread.run(UpdaterThread.java:115)

This may or may not be a GCJ problem but I don't have time to debug this issue
right now. I made some instructions on tracking down these types of problems so
if you're interested in helping with problem, that would be great. The
instructions are on the eclipse linux project wiki page:

http://wiki.eclipse.org/index.php/Debugging_Eclipse_GCJ_Problems

Feel free to post a message if you get stuck on anything. Thanks!
Comment 3 Andrew Overholt 2007-04-13 10:33:16 EDT
If the aptana plugin is open source, would you (jdub2005) consider packaging it
for Fedora?  (This is of course assuming we can fix this problem ;)
Comment 4 Kamisamanou Burgess 2007-04-13 10:43:54 EDT
I wouldn't know where to begin to package that. I'm happy to learn. See this
post I submitted at the Aptana website:
http://aptana.com/forums/viewtopic.php?t=1266
Comment 5 Andrew Overholt 2007-04-13 10:52:25 EDT
(In reply to comment #4)
> I wouldn't know where to begin to package that. I'm happy to learn.

Great!  I hate to just point you at some websites to read, so how about starting
off by taking a look at the mylar package:

cvs -d :pserver:anonymous@cvs.fedora.redhat.com:/cvs/extras co eclipse-mylar

cd into eclipse-mylar/devel and you'll see the contents of the source package
(SRPM) minus the actual source tarball.  Typing make help will tell you things
you can do.  The specfile (specfiles + sources = SRPMs which are then built into
RPMs (what you install on your system)) is eclipse-mylar.spec.  Your
eclipse-aptana.spec can probably be based on this.  Let us know as you get
further.  Discussing this on fedora-devel-java-list@redhat.com may be better
than in this bug :)

http://cvs.fedora.redhat.com/viewcvs/*checkout*/devel/eclipse-mylar/eclipse-mylar.spec?root=extras

The rest of the 
Comment 6 Ben Konrath 2007-04-27 02:36:33 EDT
Andrew, it seems you didn't finish your thought there.
Comment 7 Andrew Overholt 2007-04-27 03:58:30 EDT
Indeed it looks like I didn't :)  But now I can't remember what I was going to
say.  I think what I said was pretty decent, though.  At least to get started.  

Let us know if you run into any issues, jdub2005.
Comment 8 Ben Konrath 2007-06-07 02:50:09 EDT
I'm closing this bug because the Aptana plugin is not packaged for Fedora so I
can't debug this problem. 

Kamisamanou, please consider packaging this plugin for Fedora. If you have any
questions feel free to ask them on the fedora-devel-java list. 

Thanks, Ben

Note You need to log in before you can comment on or make changes to this bug.