Bug 235975 - libX11-1.0.3-7 breaks Opera web browser
Summary: libX11-1.0.3-7 breaks Opera web browser
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: libX11   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-11 06:49 UTC by Igor Jagec
Modified: 2018-04-11 17:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-12 12:56:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (730 bytes, text/plain)
2007-04-11 18:34 UTC, Igor Jagec
no flags Details
Xorg.0.log (20.10 KB, text/plain)
2007-04-11 18:35 UTC, Igor Jagec
no flags Details
xorg log file (20.25 KB, text/plain)
2007-04-12 10:33 UTC, Igor Jagec
no flags Details

Description Igor Jagec 2007-04-11 06:49:06 UTC
Description of problem:

libX11-1.0.3-7 breaks Opera web browser. I got some segmentation fault. I 
downgraded to libX11-1.0.3-6 and it now works fine.

Version-Release number of selected component (if applicable):

libX11-1.0.3-7

How reproducible:

Every time

Steps to Reproduce:
1. What ever it takes to make Opera web browser works fine

Actual results:

Segmentation fault of Opera web browser

Expected results:

Opera should work fine.

Comment 1 Matěj Cepl 2007-04-11 15:24:40 UTC
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.


Comment 2 Igor Jagec 2007-04-11 18:34:22 UTC
Created attachment 152308 [details]
xorg.conf

Comment 3 Igor Jagec 2007-04-11 18:35:18 UTC
Created attachment 152309 [details]
Xorg.0.log

Comment 4 Igor Jagec 2007-04-11 18:36:42 UTC
Well, I don't have problems with X, I have problems only with Opera web 
browser. I got no output from Opera web browser, except Segmentation Fault. 
Here's the files you've requested... I'll do that without xorg.conf later.

Comment 5 Igor Jagec 2007-04-12 10:33:42 UTC
Created attachment 152433 [details]
xorg log file

Comment 6 Igor Jagec 2007-04-12 10:38:09 UTC
Hm... I removed xorg.conf, but the new one wasn't generated. I sent you a new 
log file I've got. BTW I noticed the same problem on Fedora Rawhide (libX11-
1.0.3- 8.fc7.i386) and Opera 9.10 (last stable version). But, Opera 9.20beta 
works fine, but I'd radher use last stable version.

Comment 7 Igor Jagec 2007-04-12 12:22:51 UTC
Hm... it seems that Opera 9.20 becomes stable and now it works fine. I'm sorry, 
I'm not sure if I should have reported that bug :-/

Cheers!

Comment 8 Matěj Cepl 2007-04-12 12:56:44 UTC
OK, so let's close it for now, because

a) it seems to work for you,
b) the problem is apparently in Opera, which is unsupported by RedHat (it
doesn't mean, that we don't like it, it is just no part of any distribution we
ship).

If you find that it actually is Xorg problem, please, feel free to reopen this
bug and add any additionial information you will have.


Note You need to log in before you can comment on or make changes to this bug.