Bug 2360 - Creative/Ensoniq 1371 crashing sndconfig
Creative/Ensoniq 1371 crashing sndconfig
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Lawrence
Depends On:
  Show dependency treegraph
Reported: 1999-04-24 22:02 EDT by spw5
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-05-18 09:58:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description spw5 1999-04-24 22:02:13 EDT
I have a Creative/Ensoniq Soundcard which is supported by
the Linux, but when I run soundconfig, it finds the card
fine, but when it attempts to test it by playing a sample,
the program just sits at that screen, and doesn't play
anything.  so I have to use ctrl-c to exit the program.  Any
help would be greatly appreciated.
Comment 1 Bill Nottingham 1999-04-24 23:11:59 EDT
what happens if you load the driver manually?
Comment 2 Bill Nottingham 1999-04-24 23:12:59 EDT
what happens if you load the driver manually?
Comment 3 spw5 1999-04-25 01:59:59 EDT
I have tried loading the sound card manually and the same thing
happens, as when I load it with autoconfig.  It just locks up when it
tries to test it.
Comment 4 Bill Nottingham 1999-04-25 22:10:59 EDT
- Does it hang when you load the driver, or just when you try to play something?
- Is it hanging the entire computer, or just that process?
- What are the contents of /proc/pci?
Comment 5 spw5 1999-04-25 22:56:59 EDT
this is what is in /proc/pci:

PCI devices found:
  Bus  0, device  15, function  0:
    Multimedia audio controller: Ensoniq Unknown device (rev 2).
      Vendor id=1274. Device id=1371.
      Slow devsel.  IRQ 5.  Master Capable.  Latency=96.  Min
Gnt=12.Max Lat=128.
      I/O at 0x1040.
  Bus  0, device  14, function  0:
    Multimedia audio controller: Unknown vendor Unknown device (rev
      Vendor id=12eb. Device id=1.
      Medium devsel.  Fast back-to-back capable.  IRQ 10.  Master
Capable.  Latency=64.  Min Gnt=2.Max Lat=12.
      Non-prefetchable 32 bit memory at 0xf4020000.
      I/O at 0x1018.
      I/O at 0x1010.
  Bus  0, device  13, function  0:
    Ethernet controller: 3Com 3C905B 100bTX (rev 36).
      Medium devsel.  IRQ 11.  Master Capable.  Latency=32.  Min
Gnt=10.Max Lat=10.
      I/O at 0x1080.
  Bus  0, device   7, function  3:
    Bridge: Intel 82371AB PIIX4 ACPI (rev 2).
      Medium devsel.  Fast back-to-back capable.
  Bus  0, device   7, function  2:
    USB Controller: Intel 82371AB PIIX4 USB (rev 1).
      Medium devsel.  Fast back-to-back capable.  IRQ 9.  Master
Capable.  Latency=64.
      I/O at 0x1020.
  Bus  0, device   7, function  1:
    IDE interface: Intel 82371AB PIIX4 IDE (rev 1).
      Medium devsel.  Fast back-to-back capable.  Master Capable.
      I/O at 0x1000.
  Bus  0, device   7, function  0:
    ISA bridge: Intel 82371AB PIIX4 ISA (rev 2).
      Medium devsel.  Fast back-to-back capable.  Master Capable.  No
  Bus  1, device   0, function  0:
    Display controller: Texas Instruments TVP4020 Permedia 2 (rev 1).
      Medium devsel.  Fast back-to-back capable.  IRQ 11.  Master
Capable.  Latency=64.  Min Gnt=192.Max Lat=192.
      Non-prefetchable 32 bit memory at 0xf4100000.
      Non-prefetchable 32 bit memory at 0xf5000000.
      Non-prefetchable 32 bit memory at 0xf4800000.
  Bus  0, device   1, function  0:
    PCI bridge: Intel 440BX - 82443BX AGP (rev 2).
      Medium devsel.  Master Capable.  Latency=128.  Min Gnt=140.
  Bus  0, device   0, function  0:
    Host bridge: Intel 440BX - 82443BX Host (rev 2).
      Medium devsel.  Master Capable.  Latency=64.
      Prefetchable 32 bit memory at 0xf8000000.

It hangs when I try to load the driver, and if I turn on sound support
in Gnome it crashes it repeatedly.  Also X11amp did not play.  When it
crashes it just frezzes sndconfig, but if I use ctrl-c I can get back
to the prompt.
Comment 6 Bill Nottingham 1999-04-26 10:37:59 EDT
what does 'strace modprobe es1371' say?
(the last 10-20 lines only, please... :) )
Comment 7 spw5 1999-04-26 15:24:59 EDT
I ran strace modprobe es1371, I copied form when I saw something that
had es1370 in it until the end.  If this isnt enough just ask, I will
be happy to copy more of it.

stat("/lib/modules/preferred/misc/es1370.o", {st_mode=0, st_size=0,
...}) = 0
access("/lib/modules/preferred/misc/es1370.o", R_OK) = 0
stat("/lib/modules/preferred/misc/es1371.o", {st_mode=0, st_size=0,
...}) = 0
access("/lib/modules/preferred/misc/es1371.o", R_OK) = 0
open("/proc/modules", 0_RDONLY)        = 9
fstat(9, {st_mode=0,st_size=0, ...})   = 0
= 0x4000b000read(9, "3c59x          5\t\t1 {autoc"...,1024) = 200
close(9)                        = 0
munmap(0x4000b000, 4096)        = 0
 exit(0)                        = 0

Comment 8 Bill Nottingham 1999-04-26 16:12:59 EDT
wait a sec; from that, it looked like the 'modprobe es1371'
succeeded without hanging - did it? If so, what happens
then when you try to play sound?
Comment 9 spw5 1999-04-26 16:36:59 EDT
okay, the modprobe ran fine, it didn't hang or anything, but I am
still not getting any sound.  I am running Gnome, and when I turn on
sound events it tends to crash gnome, but the mixer built into gnome
recognizes that I have the es1371, because it says it in the upper
left corner.  but I have tried running x11amp, and it won't work, and
like I said the sound events won't work either.  So I don't know what
is wrong with it.
Comment 10 Bill Nottingham 1999-04-26 17:04:59 EDT
When you have the module loaded, what does
'play /usr/share/sndconfg/sample esd' do?
Also, do you have esd installed/running?
Comment 11 spw5 1999-04-26 23:02:59 EDT
the only thing in /usr/share/sndconfig is a file by the name of
sample.au and when I try to use the play command on it it just  goes
down a line and sits there, not playing anything.  I am not sure I
have esd installed, actually I am not sure what it is, so any insight
into that would be helpful.
Comment 12 Bill Nottingham 1999-04-27 00:08:59 EDT
Yes, I meant sample.au, sorry about that.
esd is esound; it's an app that mixes sound streams, and the Gnome
startup might have started it (what does 'rpm -q esound' or
'ps aux | grep esd | grep -v grep' say?
Comment 13 spw5 1999-04-27 04:45:59 EDT
well I installed, Redhat 6.0 and my sound problems have disapeared,
thanx so much for all your help, I must say this is probably the best
online tech suppor ti have ever gotten. Now if I can get x11amp to
work in gnome I will be set
Comment 14 spw5 1999-04-27 05:05:59 EDT
well this is an unrelated problem, but I figured I would ask while I
have your attn.  since I installed redhat 6.0 clean now I want to
setup my monitor to run 32bit color, and in 5.2 I just ran XF86Setup,
but that doesn't seem to exist anymore, so I was wondering how I could
get the 32 bit color.  Thanx
Comment 15 Bill Nottingham 1999-04-27 10:59:59 EDT
There should be an XFree86-XF86Setup RPM in 6.0. Also, you
can edit your /etc/X11/XF86Config file if you've already run
Xconfigurator; near the end there should be 'Screen' sections;
you can edit the 'Depth' lines there.

As for x11amp, it's probably expecting esound to be running
when it's not, or vice versa. Go to the preferences menu,
and change the output plugin; alternatively, start or
stop esd. Does that help?
Comment 16 spw5 1999-04-27 15:35:59 EDT
Well I got the X11Setup to work, but X11amp is still not doing what it
should.  I tried switching to the OSS output plugin, but that didn't
help, and I don't know how to turn on/off esound.  Right now it just
scrolls through all the songs at a really high speed trying to find
one it can play I guess, so I am not sure what to do about it, but I
am pretty sure it is some conflict with esd.
Comment 17 Bill Nottingham 1999-05-04 15:47:59 EDT
to turn esound on, run 'esd' from the command line.
to turn it off, do 'killall esd'.

(Also, playing with the sound properties in Gnome can turn esound
on and off...)
Comment 18 spw5 1999-05-04 16:46:59 EDT
Well I got, X11amp working, I installed from an official redhat cd and
it is working fine now.  I have a cd burner and I was wondering how I
could mount that.  Other than that I think everything is working fine.
Comment 19 Bill Nottingham 1999-05-10 12:20:59 EDT
the CD burner can probably be used as a SCSI generic device
(if it's SCSI) or via the idescsi driver if it's IDE.
As a CDROM, it would be /dev/scd(0,1,2) (if it's SCSI)
or /dev/hd(b,c,d) (if it's IDE), depending on what device
ID it's given.
Comment 20 Bill Nottingham 1999-05-18 09:58:59 EDT
closing because original probelm sems fixed.
Comment 21 Eric Seppanen 1999-07-27 00:21:59 EDT
Too bad this one was marked "fixed" without actually finding the
original problem.  I have the identical problem with a
Creative/Ensoniq AudioPCI  (es1371).  sndconfig detects it just fine,
but hangs when trying to play a sample sound.  The module loads ok and
finds the card.  Most sound-playing programs I've tried run, but don't
play sound (xanim, sox play).

The driver version in 5.2 is 0.3.  The driver version in RH 6.0 is
0.11... but doesn't compile under kernel 2.0.36.  Perhaps there is a
driver newer than 0.3 but older than 0.11 laying around somewhere?
Comment 22 eric_seppanen 1999-08-16 12:07:59 EDT
Here's the scoop on the es1371 driver.  It was written for linux
2.1/2.2 and somebody back-ported it to the 2.0 kernel.  That version
is now really old.  I backported the newest driver, 0.14, and it's
available from:

BTW, if trying to play sounds simply hangs and no sound comes out,
check to see if your PCI latency is set too low.  In /proc/pci, you
should see something like this:

  Bus  0, device   9, function  0:
    Multimedia audio controller: Ensoniq Unknown device (rev 6).
      Vendor id=1274. Device id=1371.
      Slow devsel.  IRQ 12.  Master Capable.  Latency=80.  Min
Gnt=12.Max Lat=128.

If "Latency" is set to zero, check if your BIOS has a setting for
this or use the newer driver linked above- it should correct the
latency automagically.

Note You need to log in before you can comment on or make changes to this bug.