Bug 23602 - part --asprimary
Summary: part --asprimary
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-08 17:40 UTC by Jos Vos
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-06 20:39:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jos Vos 2001-01-08 17:40:55 UTC
The --asprimary flag to the kickstart 'part' command does not accept a
parameter, unlike the --onprimary flag. But the Reference Guide mentions
the same syntax as --onprimary.

Comment 1 Anders Blomdell 2001-01-31 11:19:39 UTC
In my opinion the documentation is right, but the implementation is wrong (I 

therfore suggest that this bug should be reassigned as an anaconda bug):



  Without the possibility to specifiy on what number a newly created partition  

  should have, this option is not very useful.



I'll try to find a good solution to what should be done, and post a followup.





Comment 2 Anders Blomdell 2001-01-31 12:34:04 UTC
A workable fix seems to be:



--- O.kickstart.py      Wed Jan 31 12:06:14 2001

+++ kickstart.py        Wed Jan 31 12:06:57 2001

@@ -504,7 +504,7 @@

                                        'grow', 'onpart=', 'ondisk=',

                                         'bytes-per-inode=', 'usepart=',

                                         'onprimary=', 'active', 'type=',

-                                        'asprimary', 'noformat'])

+                                        'asprimary=', 'noformat'])

 

        for n in args:

            (str, arg) = n

@@ -528,6 +528,7 @@

                 active = 1

             elif str == "--asprimary":

                 primOnly = 1

+                partNum = int(arg)

             elif str == "--noformat":

                 format = 0

 



Comment 3 Tammy Fox 2001-02-02 22:54:59 UTC
Reassigned to anaconda component and changed summary to exclude the word
documentation

Comment 4 Michael Fulbright 2001-02-06 20:39:26 UTC
--asprimary does NOT take arguments. --onprimary does.


Note You need to log in before you can comment on or make changes to this bug.