Bug 23603 - RPM analog-4.13-2 improvement
RPM analog-4.13-2 improvement
Status: CLOSED RAWHIDE
Product: Red Hat Powertools
Classification: Retired
Component: analog (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-08 12:43 EST by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-15 18:21:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-01-08 12:43:50 EST
The following two improvements would be very benefitial to RPM

1. Replace
cp images/* $RPM_BUILD_ROOT/var/www/html/images
cp lang/* $RPM_BUILD_ROOT/var/lib/analog/lang
to cp -p (add -p flag to cp)
so original creation dates of images and etc. will be preserved.

2. Replace the directory /var/www/html/images/  
to /var/www/html/analogimages/  
The replacement of /images/ to /analogimages/
will help to avoid a very common name clash,
because the name /images/ is too generic and often already used 
on a web site.
The compilation parameter -DIMAGEDIR=
if put to "/analogimages/" and slight spec adjustment will do the job
Comment 1 Need Real Name 2001-01-09 11:42:17 EST
The analog-4.13-2 now seems in rawhide,
but there is not analog in the rawhide packages menu.
So I am posting the report here, in web server.
Comment 2 Tim Powers 2001-01-09 13:01:54 EST
Your first suggestion doesn't really add anything to the package, the second is
being implmented, and should show up in rawhide shortly.

Tim
Comment 3 Need Real Name 2001-01-09 13:12:27 EST
First suggestion, from my point of view,
is important because once you do "page info"
on a report page you will see true dates of the images,
not the date when RPM was built.
With different dates the images look like different ones from original analog. 
Similar problem with lang files.
If the dates are original it will be for example easier to identify
the version of translation files which has a misspell or something like that.

Another reason - consistency with apache and the other programs
Do  ls -l /var/www/icons/
and the icons from apache have dates  from 1996,
they have the true dates when the images were created.
Comment 4 Tim Powers 2001-01-09 13:25:16 EST
Well, there are two ways to look at it then:

1. Your view regarding the dates
2. build date, then all parts of the package have the same date, and can easily
be tracked as well.

Both of these have the same results, even though the dates aren't from the tarball.

Tim
Comment 5 Need Real Name 2001-01-09 13:30:30 EST
In all packages like: apache, netscape, wv, control-panel, etc.
images and translations have the original date from tar sources.
Comment 6 Tim Powers 2001-01-09 13:49:47 EST
Not all of them preserve the dates. But, I'll do this since you really, really
want me to :)

Tim
Comment 7 Need Real Name 2001-01-15 18:21:30 EST
There is a problem with analog-4.13-3 (from rawhide).
The images prefix in logreports now set to 
analogimages/
Because there is no / in the beginning
it works only if logreport is the the server root directory.
In case if logreport is in the other directory 
then analogimages/ is just appended to that 
original URL and image is not fond.

The fix is to make URL absolute (add / in the beginning of image prefix)
in the program.

Also, another problem:
The file /var/www/html/anlgform.html 
has correct URL img src="/analogimages/analogo.gif" alt="",
but this file seems have the directory wrong in another place:
<input type=hidden name="IMAGEDIR" value="/images/">

(the value  gas correct / in the beginning, but it should be /analogimages/,
not /images/)
Comment 8 Tim Powers 2001-01-19 17:51:58 EST
OK. This is should be fixed (I think it is anyway) in the -4 release of the
package. It should show up in rawhide the next time it's updated.

Tim

Note You need to log in before you can comment on or make changes to this bug.