Bug 236075 - stat failure errors while doing cmirror creation/deletion operations
stat failure errors while doing cmirror creation/deletion operations
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: lvm2-cluster (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Milan Broz
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-11 16:10 EDT by Corey Marthaler
Modified: 2013-02-28 23:05 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-17 08:25:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2007-04-11 16:10:01 EDT
Description of problem:
In an attempt to verify the fix for bz 213754, I was doing looping create/delete
operations from all 4 nodes in my cluster. This caused some of these operations
to report different stat/lstat errors, even though the operations succeeded.
Also, this may be an lvm2-cluster issue and not necessarily cmirror specific.

Is this happening besause of the deletes on other nodes during the creation process?


[root@link-08 ~]# lvcreate -m 1 -n $(hostname).1 -L500M feist
  /dev/dm-6: stat failed: No such file or directory
  Path /dev/dm-6 no longer valid for device(253,6)
  /dev/mapper/feist-link--02.2_mlog: stat failed: No such file or directory
  Path /dev/mapper/feist-link--02.2_mlog no longer valid for device(253,6)
  Aborting - please provide new pathname for what used to be
/dev/mapper/feist-link--02.2_mlog
  /dev/dm-7: stat failed: No such file or directory
  Path /dev/dm-7 no longer valid for device(253,7)
  /dev/mapper/feist-link--02.2_mimage_0: stat failed: No such file or directory
  Path /dev/mapper/feist-link--02.2_mimage_0 no longer valid for device(253,7)
  Aborting - please provide new pathname for what used to be
/dev/mapper/feist-link--02.2_mimage_0
  /dev/dm-8: stat failed: No such file or directory
  Path /dev/dm-8 no longer valid for device(253,8)
  /dev/mapper/feist-link--02.2_mimage_1: stat failed: No such file or directory
  Path /dev/mapper/feist-link--02.2_mimage_1 no longer valid for device(253,8)
  Aborting - please provide new pathname for what used to be
/dev/mapper/feist-link--02.2_mimage_1
  /dev/dm-9: stat failed: No such file or directory
  Path /dev/dm-9 no longer valid for device(253,9)
  /dev/mapper/feist-link--02.2_mimage_2: stat failed: No such file or directory
  Path /dev/mapper/feist-link--02.2_mimage_2 no longer valid for device(253,9)
  Aborting - please provide new pathname for what used to be
/dev/mapper/feist-link--02.2_mimage_2
  /dev/dm-10: stat failed: No such file or directory
  Path /dev/dm-10 no longer valid for device(253,10)
  /dev/feist/link-02.2: stat failed: No such file or directory
  Path /dev/feist/link-02.2 no longer valid for device(253,10)
  /dev/mapper/feist-link--02.2: stat failed: No such file or directory
  Path /dev/mapper/feist-link--02.2 no longer valid for device(253,10)
  Aborting - please provide new pathname for what used to be
/dev/mapper/feist-link--02.2
  /dev/mapper/feist-link--02.2_mlog: lstat failed: No such file or directory
  /dev/mapper/feist-link--02.2_mimage_2: lstat failed: No such file or directory
  Logical volume "link-08.1" created



Version-Release number of selected component (if applicable):
[root@link-08 ~]# rpm -q lvm2
lvm2-2.02.21-3.el4
[root@link-08 ~]# rpm -q lvm2-cluster
lvm2-cluster-2.02.21-3.el4
[root@link-08 ~]# rpm -q cmirror-kernel
cmirror-kernel-2.6.9-30.0
Comment 1 Jonathan Earl Brassow 2007-04-19 10:49:27 EDT
could we get a -vvvv output for this?
Comment 3 Jonathan Earl Brassow 2008-03-26 14:25:17 EDT
I see this often as well.  It appears that device-mapper devices are being put
in the LVM cache - then LVM commands complain when it doesn't find them (because
another machine removed them while the lvm command was in progress?).

Comment 6 Milan Broz 2010-05-17 08:25:52 EDT
I think there were so many changes to this code, some of them surely fixes at least part of this... 

If you still see this, please reopen, thanks.

Note You need to log in before you can comment on or make changes to this bug.