Bug 236135 - RPCbind conflicts with glibc
RPCbind conflicts with glibc
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpcbind (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
:
: 236708 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-11 21:37 EDT by Marc Wiriadisastra
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-20 10:29:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Wiriadisastra 2007-04-11 21:37:28 EDT
Description of problem:
Doing an update in FC6 test 3 the latest test I tried to do an update with all
the new packages and the following error gets spit out.

[('file /usr/sbin/rpcinfo from install of rpcbind-0.1.4-3.fc7 conflicts with
file from package glibc-common-2.5.90-19', (7, '/usr/sbin/rpcinfo', 0L))]

How reproducible:

It happens every time I try to update.

Steps to Reproduce:
1. yum -y update
  
Actual results:

[('file /usr/sbin/rpcinfo from install of rpcbind-0.1.4-3.fc7 conflicts with
file from package glibc-common-2.5.90-19', (7, '/usr/sbin/rpcinfo', 0L))]

Expected results:

It should update rpcbind

Additional info:

It's run in vmware but I don't believe that should make an issue since it is a
package related issue.
Comment 1 Matthew Miller 2007-04-12 08:58:26 EDT
Although it's far from obvious, all Fedora 7 test bugs should be filed against
"devel", not "test#". Moving this, so it doesn't get lost.

This has been a bulk message. We return you now to your regularly scheduled
program, already in progress.
Comment 2 Steve Dickson 2007-04-17 09:14:26 EDT
Are you running Rawhide or FC6? It sounds like
the repos your using are pointed to Rawhide
instead of FC6...

Note: I'm running a number of FC6 machines,
doing yum updates daily, and I'm not seeing
this problem
Comment 3 Marc Wiriadisastra 2007-04-17 09:18:15 EDT
I'm running rawhide.
Comment 4 Valent Turkovic 2007-04-17 09:35:49 EDT
I have a Fedora7 test3 setup and I get this error also. I filed a duplicated bug
report.
Comment 5 Marc Wiriadisastra 2007-04-17 09:43:14 EDT
Yeah I have Fedora 7 Test 3 but I've been told to call it rawhide.  Not sure if
that makes a difference or not.
Comment 6 Steve Dickson 2007-04-17 16:22:04 EDT
Well because the rpcbind rpm now supplies the rpcinfo
command and its man page, they had to be removed
from the glibc-common and man-pages (respectively) 
rpms otherwise there would be a confliction...

So I need to added a Requires: clause to
ensure the correct rpms are installed. 

The needed rpms are:
glibc-common-2.5.90-20
man-pages-2.43-12

So please try 'yum update glibc-common man-pages rpcbind'
which should fix things up.
Comment 7 Jeremy Katz 2007-04-19 16:48:25 EDT
*** Bug 236708 has been marked as a duplicate of this bug. ***
Comment 8 Valent Turkovic 2007-04-19 17:10:25 EDT
I tried normal 'yum update' on Fedora 7 test 3 - and it passes update without
conflict. For me this is a squashed bug :)
Good work guys.
Thank you.
Comment 9 Marc Wiriadisastra 2007-04-19 20:16:57 EDT
Yep it works fine for me as well.

Note You need to log in before you can comment on or make changes to this bug.