Bug 236159 - PyOpenGL should depend on freeglut
Summary: PyOpenGL should depend on freeglut
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: PyOpenGL   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL: https://www.redhat.com/archives/fedor...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-12 06:00 UTC by Peter Gordon
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-13 19:13:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Gordon 2007-04-12 06:00:42 UTC
Hi, Hans.

As noted in the linked fedora-test-list post by Rodd Clarkson shows, PyOpenGL
goes ker-splat with a traceback due to the system not finding the glut library. 
Installeing the freeglut package fixes this.

Thus, please add freeglut as a hard dependency of PyOpenGL so that these
tracebacks no longer occur. Thanks.

(A simple "Requires: freeglut" in the spec file should do it, methinks.)

Comment 1 Hans de Goede 2007-04-13 19:13:30 UTC
I've just send a fixed version to the buildsys for both FC-6 and devel, it
should show up on a mirror near you within the next few days.

Thanks for reporting this.



Note You need to log in before you can comment on or make changes to this bug.