Bug 236194 - cdrkit packages: Bad Provides + conflicts
cdrkit packages: Bad Provides + conflicts
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cdrkit (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: FE7Target
  Show dependency treegraph
 
Reported: 2007-04-12 09:34 EDT by Michael Schwendt
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-21 06:34:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2007-04-12 09:34:33 EDT
> genisoimage - 1.1.2-3.fc7.i386  
> provides mkisofs EQ 9 2.01 10.1 
> fedora-extras-development-i386
>    but there is: mkisofs - 9:2.01-11.fc7.i386

Please remove the "Provides: mkisofs = ..." from the package.

Installing mkisofs removes genisoimage. For background refer
to the current gtkhtml38 thread on fedora-test-list and the ticket
linked therein.
Comment 1 Michael Schwendt 2007-04-12 09:36:14 EDT
False positive, it seems.
Comment 2 Michael Schwendt 2007-04-12 09:37:28 EDT
Updating to  mkisofs-2.01-11.fc7.i386.rpm  removes genisoimage
Comment 3 Michael Schwendt 2007-04-12 09:56:32 EDT
-icedax and -wodim packages are affected, too, because the cdrecord
and cdda2wav pkgs in core are newer:

$ rpm -q genisoimage
genisoimage-1.1.2-3.fc7
$ yum install mkisofs
[...]
Running Transaction
  Installing: mkisofs                      ######################### [1/2] 
  Removing  : genisoimage                  ######################### [2/2]

$ rpm -q mkisofs
mkisofs-2.01-11.fc7
$ yum install genisoimage
[...]
Transaction Check Error:
  file /usr/bin/isodebug from install of genisoimage-1.1.2-3.fc7 conflicts with
file from package mkisofs-2.01-11.fc7
  file /usr/bin/isodump from install of genisoimage-1.1.2-3.fc7 conflicts with
file from package mkisofs-2.01-11.fc7
  file /usr/bin/isoinfo from install of genisoimage-1.1.2-3.fc7 conflicts with
file from package mkisofs-2.01-11.fc7
  file /usr/bin/isovfy from install of genisoimage-1.1.2-3.fc7 conflicts with
file from package mkisofs-2.01-11.fc7
  file /usr/bin/mkhybrid from install of genisoimage-1.1.2-3.fc7 conflicts with
file from package mkisofs-2.01-11.fc7
  file /usr/bin/mkisofs from install of genisoimage-1.1.2-3.fc7 conflicts with
file from package mkisofs-2.01-11.fc7


Is this really expected? The Obsoletes and Provides cause rpm to
jump forth and back between the packages in Extras and Core until
there is a conflict, because the packages in Core are newer than
what is obsoleted by the cdrkit packages.
Comment 4 Harald Hoyer 2007-04-16 09:57:21 EDT
Hmm, better remove the version numbers from Obsoletes and Provides??
Comment 5 Harald Hoyer 2007-04-16 10:11:10 EDT
another alternative would be "alternatives"
Comment 6 Jason Tibbitts 2007-04-16 10:54:53 EDT
The packages which cdrkit obsoletes were supposed to be removed from core.  As
far as I can tell, cdrkit is providing and obsoleting precisely what is should,
but the core stuff did not go away as it should have.

I think that's something to take up with whoever is supposed to ensure that
those packages be removed.
Comment 7 Jason Tibbitts 2007-04-16 14:59:00 EDT
OK, I dropped into the releng meeting.  The plan seems to be to get this fixed
as part of the merge, which supposedly will happen before the release.  The old
packages will be dropped at that time.  (If it doesn't happen before the
release, I have no idea what's going to happen, but those packages can't be
pulled now or else a bunch of other stuff in core will end up with broken
dependencies.)

What needs to happen now is to fix up the Obsoletes: and Provides: for the
cdrkit packages so that they are actually higher than the obsolete packages
currently in rawhide.  It seems those packages were bumped just after cdrkit was
approved.  There's no need to worry about alternatives.

Note You need to log in before you can comment on or make changes to this bug.