Bug 23620 - Backspace not working with 106 keyboard in X
Backspace not working with 106 keyboard in X
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0J
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Mike A. Harris
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-08 16:41 EST by Becky Miller
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-25 22:42:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Becky Miller 2001-01-08 16:41:02 EST
The backspace key on a Dell The backspace and delete keys are both mapped
to forward erase key code.  Control-H must be used to backspace when using
X.  To get the backspace key to work one must edit the file
/etc/X11/Xmodmap   and uncomment the i386 xmodmap line for the backspace.
Comment 1 Mike A. Harris 2001-02-16 10:41:02 EST
Is this some special keyboard that isn't directly supported by XFree86?
Can you please attach the X server log from a session where the glitch is
active, as well as your X configuration file.  Also, what version of XFree
server is running - 3.3.6 or 4.0.x/

The global Xmodmap file is intended for local configuration to override the
system default.  If there is a problem with the Dell keyboard not working
as expected, the proper solution would be adding support in the main
XFree86 package.  I'd need to know the details of your setup.  I also
might need a 106 key keyboard in order to solve this correctly unless
someone that has one could figure it out and send me a patch.
Comment 2 Mike A. Harris 2001-04-25 22:40:16 EDT
I am unable to diagnose this problem without the hardware, and nothing seems
obvious from looking at any keymap files.  It might be that a new map file is
needed especially for this keyboard.  If you could arrange for me to be sent
a Dell 106 key keyboard, I will add support for it as soon as I can.

Let me know via email and I'll send you my shipping address, and you can
forward this request to someone at Dell who can send me a board to work with.

TIA

Note You need to log in before you can comment on or make changes to this bug.