Bug 236262 - Could not find root file system /dev/root (on initial startup from 6.92 LiveCD)
Could not find root file system /dev/root (on initial startup from 6.92 LiveCD)
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2007-04-12 14:44 EDT by Domenick Rowe
Modified: 2007-12-18 17:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-12-18 17:15:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
lspci and dmesg output from SuSe on same hardware that fails LiveCD (20.01 KB, text/plain)
2007-04-26 23:42 EDT, Mike Laughton
no flags Details

  None (edit)
Description Domenick Rowe 2007-04-12 14:44:13 EDT
Description of problem:
I have an HP Pavillion zd8000. I currently have debian installed but am trying
to switch to FC. When I boot from the liveCD, I get this error message, a
request to create a symlink and then type exit to get out of the shell (even
though it seems the installation keeps trying to continue). I don't understand,
because it's booting from the CD, not the HDD. Please dumb the answer down a
bit--I'm a newcomer to linux (but not computers). If there's any additional
information needed to solve this, ask me here or via email at dprowe78@comcast.net

Version-Release number of selected component (if applicable):
FC 6.92

How reproducible:
Every time

Steps to Reproduce:
1.boot from disc

Actual results:
system enters an endless loop after the error message...something with ata1.1
(if that means anything to you).

Expected results:
successful boot

Additional info:
I'll attach a bootlog file if it's helpful and someone tells me how.
Comment 1 Dave Jones 2007-04-23 15:53:50 EDT
if you could boot into your debian install and attach the output of 'lspci' and
'dmesg' that might give some clues.
Comment 2 Mike Laughton 2007-04-26 23:42:41 EDT
Created attachment 153576 [details]
lspci and dmesg output from SuSe on same hardware that fails LiveCD

I have been having the same problem (can't boot from LiveCD due to missing
/dev/root) since F7 Test 1, 2, 3, and now 4.  Attached is the output from lspci
and dmesg, as requested from the original poster.
Comment 3 Chuck Ebbert 2007-04-27 16:29:03 EDT
IDE interface: ALi Corporation M5229 IDE
Comment 4 Thomas J. Baker 2007-05-31 14:43:14 EDT
I don't know if this is the best bug for me to add to but I just installed F7
from DVD and had the same problem. I've got a standard Intel ICH7 IDE
controller. I had to boot a rescue disk and fix references to a labeled root
partition in fstab and grub.conf. Booting by LABEL=/ was not working.
Comment 5 David Rector 2007-12-15 10:04:37 EST
Hello Everyone,

I am helping a friend to install Fedora 8 on his laptop.

It is a HP pavilion dv9000 with Vista. After partitioning the disk with
qtparted, we installed FC8 x86_64 with no glitches.

On the first boot, we never get any joy because the system always gives us
/dev/root not found and stops with a kernel panic.

I have searched bugzilla and Fedora Forum for a solution, but I think this is
still a serious bug. Many people had this problem when FreeBSD was installed on
their drive, or had a RAID drive. But in this case, there are only four
partitions, two for Vista, one for linux root and one for linux swap.

I have tried turning off apic and apm in grub, but no joy.
I have tried booting the rescue disk and reinstalling GRUB, still no joy.
I have tried booting the rescue disk, doing a yum update, and rerunning mkinitrd
as suggested in other bug reports, still doesn't work.

I suspect there is something in the sata hard drive driver, however, I am
curious why the system boots fine using the install disk?

Thanks in advance.
Comment 6 David Rector 2007-12-15 12:42:30 EST
One other point,

Changing root=/dev/sda3 from LABEL=/ did not work either.
Comment 7 Chuck Ebbert 2007-12-18 17:15:32 EST
Problems with ALi controller (the original report) should be fixed by now.

Fedora 7 (and 8) respins are at http://spins.fedoraunity.org/spins

Note You need to log in before you can comment on or make changes to this bug.