Bug 236312 - unzip can't open file larger than 2GB
unzip can't open file larger than 2GB
Status: CLOSED DUPLICATE of bug 199104
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: unzip (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-12 20:15 EDT by Guru Anbalagane
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-13 04:17:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guru Anbalagane 2007-04-12 20:15:18 EDT
Description of problem:
create a zipfile greater than 2gb on a windows OS, ftp in binary to linux,
and unzip: 

Version-Release number of selected component (if applicable):
UnZip 5.51 

How reproducible:
always

Steps to Reproduce:
1.try to unzip a file larger than 2 GB
2.
3.
  
Actual results:
can't find file

Expected results:
should open it

Additional info:
it suffices to add -D_LARGEFILE_SOURCE to CF (compile flags) in the
Makefile.
oracle bug number 5631207
Comment 1 Ivana Varekova 2007-04-13 04:17:16 EDT

*** This bug has been marked as a duplicate of 199104 ***

Note You need to log in before you can comment on or make changes to this bug.