Bug 236314 - abiword fails to convert .doc files to other formats (libgsf error)
abiword fails to convert .doc files to other formats (libgsf error)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: abiword (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marc Maurer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-12 22:05 EDT by James Hunt
Modified: 2008-06-16 21:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 21:17:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Hunt 2007-04-12 22:05:44 EDT
Description of problem:

abiword's command line conversion fails to produce correct output.

Version-Release number of selected component (if applicable):

abiword-2.4.6-1.fc6

How reproducible:

Every time.

Steps to Reproduce:
1. abiword --to=odt file.doc
  
Actual results:

(AbiWord-2.4:19159): libgsf:msole-CRITICAL **: ole_get_block: assertion `block <
ole->info->max_block' failed

file.odt is produced, but it only contains some of the data in the original Word
file.

Expected results:


Additional info:

I've tried a variety of .doc files, and have also tried --to=abw, --to=sxw,
but the problem is the same (libgsf CRITICAL msg).
Comment 1 Marc Maurer 2007-04-13 04:54:53 EDT
This is most likely a problem with the .doc importer, NOT the exporter. Could
you attach the MS Word Document so we can try to find out what is going wrong here?

The libgsf CRITICAL msg comes from the WordPerfect file scanning routine
misusing gsf.
Comment 2 James Hunt 2007-04-18 21:46:49 EDT
It's not the word doc content. I just created a new word file (in
OpenOffice.org) containing a single character 'a', and tried to do the
conversion with abiword again. Same Barf.
Comment 3 Till Maas 2008-01-06 08:32:07 EST
The libgsf:msole-CRITICAL message still appears on Fedora 7 with abiword.i386
1:2.4.6-5.fc7
Comment 4 Marc Maurer 2008-01-06 10:04:44 EST
The libgsf:msole-CRITICAL message is unrelated, and comes from the WordPerfect
document detection code. This message will be removed in AbiWord 2.6.

Note: Without any attached sample document, this bug will not be fixed.
Comment 5 Bug Zapper 2008-05-14 08:12:25 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2008-06-16 21:17:39 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.