Bug 236315 - Xen kernel does not work with LVM/XFS root file system
Summary: Xen kernel does not work with LVM/XFS root file system
Status: CLOSED DUPLICATE of bug 212201
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 6
Hardware: x86_64 Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-13 02:18 UTC by Chris Palmieri
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 14:57:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Palmieri 2007-04-13 02:18:20 UTC
Description of problem:
Xen kernel does not work with LVM/XFS root file system

Version-Release number of selected component (if applicable):


How reproducible:
Installed with Xen kernel installed with root (/) as a XFS file system under LVM.


Steps to Reproduce:
1. install xfs (Configure install using XFS)
2. Install Xen components
3. Reboot
  
Actual results:
XFS I/O errors

Expected results:
Kernel/OS boots

Additional info:

Comment 1 Stephen Tweedie 2007-04-18 14:33:47 UTC
Could you include the actual errors, please?


Comment 2 Chris Palmieri 2007-04-18 23:55:28 UTC
To be honest I blew away that installation to get myself up and running.  I also
found out it is not just the Xen kernel - the standard fc6 kernel also does not
boot with xfs configured.  I could try to create a new partition and install on
there if needed but it will take me a while to get around to doing it.

Comment 3 Eric Sandeen 2007-04-20 20:28:44 UTC
Chris, you probably hit bug #212201, if you had selinux enabled.

A workaround is to install w/o selinux, update your kernel, then re-enable selinux.

-Eric

Comment 4 Eric Sandeen 2007-05-01 14:57:14 UTC
Lacking more detailed info, I assume this was a dup of bug 212201.  Feel free to
re-open if you find out otherwise.

Thanks,
-Eric

*** This bug has been marked as a duplicate of 212201 ***


Note You need to log in before you can comment on or make changes to this bug.