Bug 236342 - Thunderbird fails to start when X is forwarded over SSH
Summary: Thunderbird fails to start when X is forwarded over SSH
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: thunderbird   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-13 11:04 UTC by Jonathan Underwood
Modified: 2018-04-11 08:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-14 14:46:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of strace -o strace.out thunderbird (26.70 KB, text/plain)
2007-04-13 11:05 UTC, Jonathan Underwood
no flags Details

Description Jonathan Underwood 2007-04-13 11:04:15 UTC
Description of problem:
Logging into remote machine with ssh -X or ssh -Y and typing thunderbird at the
command prompt doesn't start thunderbird. Other applications start fine (eg.
xterm, firefox).

Version-Release number of selected component (if applicable):
thunderbird-1.5.0.10-1.fc6


How reproducible:
Everytime

Steps to Reproduce:
1.ssh -X or ssh -Y to a remote machine
2.thunderbird
3.
  
Actual results:
Thunderbird not started, command prompt returned.

Expected results:
Thunderbird starts

Additional info:
Installed debuginfo packages and tried thunderbird -g:

/usr/lib64/thunderbird-1.5.0.10/run-mozilla.sh -g
/usr/lib64/thunderbird-1.5.0.10/thunderbird-bin
MOZILLA_FIVE_HOME=/usr/lib64/thunderbird-1.5.0.10
 
LD_LIBRARY_PATH=/usr/lib64/thunderbird-1.5.0.10:/usr/lib64/thunderbird-1.5.0.10/plugins:/usr/local/lib/mre/mre-1.5.0.10
DISPLAY=localhost:10.0
DYLD_LIBRARY_PATH=/usr/lib64/thunderbird-1.5.0.10:/usr/local/lib/mre/mre-1.5.0.10
    
LIBRARY_PATH=/usr/lib64/thunderbird-1.5.0.10:/usr/lib64/thunderbird-1.5.0.10/components:/usr/local/lib/mre/mre-1.5.0.10
       SHLIB_PATH=/usr/lib64/thunderbird-1.5.0.10:/usr/local/lib/mre/mre-1.5.0.10
          LIBPATH=/usr/lib64/thunderbird-1.5.0.10:/usr/local/lib/mre/mre-1.5.0.10
       ADDON_PATH=/usr/lib64/thunderbird-1.5.0.10
      MOZ_PROGRAM=/usr/lib64/thunderbird-1.5.0.10/thunderbird-bin
      MOZ_TOOLKIT=
        moz_debug=1
     moz_debugger=
which: no ddd in
(/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/home/jgu/local/bin)
/usr/bin/gdb /usr/lib64/thunderbird-1.5.0.10/thunderbird-bin -x /tmp/mozargs.r18772
GNU gdb Red Hat Linux (6.5-15.fc6rh)
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu"...(no debugging symbols found)
Using host libthread_db library "/lib64/libthread_db.so.1".

(gdb) bt
No stack.
(gdb) q


Will attach the output of strace in the next message.

Comment 1 Jonathan Underwood 2007-04-13 11:05:33 UTC
Created attachment 152533 [details]
Output of strace -o strace.out thunderbird

Output of strace -o strace.out thunderbird

Comment 2 Christopher Aillon 2007-04-13 14:54:18 UTC
Is thunderbird already running on the box on the local console?  Can you run "sh
-x thunderbird" as well?

Comment 3 Jonathan Underwood 2007-04-13 15:04:02 UTC
Aha, Thunderbird was indeed running on the local box. Shutting down the local
thunderbird allows the remote one to run. This is rather odd behaviour, very
counterintuitive to the naive user (me :) )... is this by design? If it is by
design, some sort of message explaining what is going on would be useful.

With local thunderbird running, sh -x thunderbird gives:
$ sh -x thunderbird
+ MOZ_LIB_DIR=/usr/lib
+ '[' -x /usr/lib64/thunderbird-1.5.0.10/thunderbird-bin ']'
+ MOZ_LIB_DIR=/usr/lib64
+ MOZILLA_FIVE_HOME=/usr/lib64/thunderbird-1.5.0.10
+ MRE_HOME=/usr/lib64/thunderbird-1.5.0.10
+ export MOZILLA_FIVE_HOME MRE_HOME
+ MOZ_PROGRAM=/usr/lib64/thunderbird-1.5.0.10/thunderbird
+ MOZ_CLIENT_PROGRAM='/usr/lib64/thunderbird-1.5.0.10/thunderbird -remote'
+ MOZARGS=
++ check_running
++ /usr/lib64/thunderbird-1.5.0.10/thunderbird -remote 'ping()'
++ RETURN_VAL=0
++ '[' 0 -eq 2 ']'
++ echo 1
++ return 1
+ ALREADY_RUNNING=1
+ '[' -z '' ']'
+ '[' 1 -eq 1 ']'
+ exec /usr/lib64/thunderbird-1.5.0.10/thunderbird -remote 'xfeDoCommand(openInbox)'


And without local thunderbird running:
sh -x thunderbird
+ MOZ_LIB_DIR=/usr/lib
+ '[' -x /usr/lib64/thunderbird-1.5.0.10/thunderbird-bin ']'
+ MOZ_LIB_DIR=/usr/lib64
+ MOZILLA_FIVE_HOME=/usr/lib64/thunderbird-1.5.0.10
+ MRE_HOME=/usr/lib64/thunderbird-1.5.0.10
+ export MOZILLA_FIVE_HOME MRE_HOME
+ MOZ_PROGRAM=/usr/lib64/thunderbird-1.5.0.10/thunderbird
+ MOZ_CLIENT_PROGRAM='/usr/lib64/thunderbird-1.5.0.10/thunderbird -remote'
+ MOZARGS=
++ check_running
++ /usr/lib64/thunderbird-1.5.0.10/thunderbird -remote 'ping()'
++ RETURN_VAL=2
++ '[' 2 -eq 2 ']'
++ echo 0
++ return 0
+ ALREADY_RUNNING=0
+ '[' -z '' ']'
+ '[' 0 -eq 1 ']'
+ rm_shit
+ find /home/jgu/.thunderbird -name XUL.mfasl
+ xargs rm -f
+ exec /usr/lib64/thunderbird-1.5.0.10/thunderbird


Comment 4 Matěj Cepl 2007-12-10 09:21:54 UTC
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]

Comment 5 Jonathan Underwood 2008-01-13 12:49:02 UTC
Yes this problem is still present - I personally regard it as a design flaw
rather than a bug - it's actually working as the packager intended, but I think
that is misguided. Basically the thunderbird and firefox scripts have logic in
them which says "If i am being asked to run on a remote X server, and there is a
localinstance of thunderbird/firefox running on that machine, don't start". No
other application behaves in this way, so why on earth would we want
thunderbird/firefox to do this? 

Comment 6 Christopher Aillon 2008-01-13 13:05:13 UTC
With thunderbird 2.0, try:

  thunderbird -no-remote



Comment 7 Matěj Cepl 2008-02-14 14:46:49 UTC
Although I personally don't like this behavior myself, Firefox/TB here behaves
as documented, so this is not a bug in technical meaning of the word.

Closing as NOTABUG


Note You need to log in before you can comment on or make changes to this bug.