Bug 236350 - Missconfiguration
Summary: Missconfiguration
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: radiusclient-ng   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeffrey C. Ollie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-13 12:11 UTC by Victor Romero
Modified: 2008-04-09 05:19 UTC (History)
1 user (show)

Fixed In Version: 0.5.6-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 05:15:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix patch (537 bytes, patch)
2008-01-08 02:43 UTC, Chris Adams
no flags Details | Diff

Description Victor Romero 2007-04-13 12:11:53 UTC
Description of problem:
Config file /etc/radiusclient-ng/radiusclient.conf contains the line 
dictionary     @pkgdatadir@/dictionary
that should be
dictionary      /usr/share/radiusclient-ng/dictionary


Version-Release number of selected component (if applicable):
Version     : 0.5.2                             Vendor: Fedora Project
Release     : 4.fc6                         Build Date: mar 29 ago 2006 04:21:18
CEST


How reproducible:
Always

Steps to Reproduce:
1. cat /etc/radiusclient-ng/radiusclient.conf | grep 
  
Actual results:
dictionary     @pkgdatadir@/dictionary


Expected results:
dictionary      /usr/share/radiusclient-ng/dictionary

Additional info:

Comment 1 Chris Adams 2007-08-13 13:27:59 UTC
This is still a problem in FC6, F7, and the current rawhide version.

Comment 2 Chris Adams 2007-08-19 13:33:10 UTC
There's a new version in updates-testing for F7 but it still has the same problem.

Comment 3 Chris Adams 2007-12-17 02:31:26 UTC
Still a problem in F8.

Comment 4 Chris Adams 2008-01-08 02:43:46 UTC
Created attachment 291032 [details]
Patch to fix patch

This appears to be caused by the Fedora patch in the SRPM.  It changes the
radiusclient.conf.in to reference @pkgdatadir@ but not the Makefile.am to make
the proper substitution.

The attached one-line patch (on top of the existing patch) fixes this; please
include it for F9.

Comment 5 Chris Adams 2008-02-03 01:50:46 UTC
This is a simple and obvious fix.  Can we please get this at least included in
rawhide before Fedora 9 (and preferably updated in F7, F8, and EPEL 5)?

Comment 6 Fedora Update System 2008-02-03 02:58:35 UTC
radiusclient-ng-0.5.6-3.fc7 has been submitted as an update for Fedora 7

Comment 7 Fedora Update System 2008-02-03 03:01:57 UTC
radiusclient-ng-0.5.6-3.fc8 has been submitted as an update for Fedora 8

Comment 8 Jeffrey C. Ollie 2008-02-03 03:16:52 UTC
Builds with the updated patch have been submitted for rawhide, F-7, F-8 and EL-5.

Comment 9 Fedora Update System 2008-02-07 20:59:02 UTC
radiusclient-ng-0.5.6-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update radiusclient-ng'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-1372

Comment 10 Chris Adams 2008-04-05 00:16:57 UTC
How long is this going to stay in updates-testing for F7 and F8?

Comment 11 Jeffrey C. Ollie 2008-04-05 00:48:47 UTC
If they get 3 karma points in bodhi they will be automatically moved to the
updates.  Otherwise I need to request that they be moved over.  Can you confirm
that the patches worked?

Comment 12 Chris Adams 2008-04-05 00:58:34 UTC
Yes, I can confirm the problem is fixed (I gave the F7 update a +1).

Comment 13 Fedora Update System 2008-04-09 05:15:08 UTC
radiusclient-ng-0.5.6-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2008-04-09 05:19:03 UTC
radiusclient-ng-0.5.6-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.