Bug 236378 - Eclipse 3.1.2 Binary Hangs
Eclipse 3.1.2 Binary Hangs
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: eclipse (Show other bugs)
5.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-13 10:55 EDT by Mike Millson
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-16 04:30:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Startup error message. (12.05 KB, image/png)
2007-04-13 10:55 EDT, Mike Millson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Eclipse Project 182336 None None None Never

  None (edit)
Description Mike Millson 2007-04-13 10:55:20 EDT
Description of problem:
The JBoss IDE splash screen appears, then the "Select A Workspace" dialogue.
After I select my workspace and click OK, Eclipse shows packages that it is
loading. The last package loaded ends in ui.forms. Then the following error
message is displayed (see attached screen shot):

Problems Opening Page

XPCOM error -2147467262

When I click the OK button on the error dialogue, the "Welcome to JBoss IDE 1.6"
dialogue is displayed. I cancel out of this dialogue (nothing to convert), and
nothing is displayed. Eclipse just hangs.

Steps to Reproduce:
1. Download the JBossIDE-1.6.0.GA-Bundle-linux-gtk bundle
2. Make eclipse binary executable (chmod +x eclipse)
3. Run the eclipse binary (./eclipse)
  
Actual results:
The JBoss IDE splash screen appears, then the "Select A Workspace" dialogue.
After I select my workspace and click OK, Eclipse shows packages that it is
loading. The last package loaded ends in ui.forms. Then the following error
message is displayed (see attached screen shot):

Problems Opening Page

XPCOM error -2147467262

When I click the OK button on the error dialogue, the "Welcome to JBoss IDE 1.6"
dialogue is displayed. I cancel out of this dialogue (nothing to convert), and
nothing is displayed. Eclipse just hangs. 


Expected results:
I should see the Eclpse first launch welcome page.


Additional info:
This also happens with the stock Eclipse 3.1.2

I have found a workaround. Instead of executing the eclipse binary directly, I
start eclipse as follows:

java -jar startup.jar

This creates the following directories inside the configuration directory:
org.eclipse.core.runtime
org.eclipse.osgi
org.eclipse.update

And it creates the following file inside the configuration directory:
.settings

Eclipse starts up without any errors. Then if I run the eclipse executable
directly, it starts. Apparently it was not starting up before because it was not
able to create the configuration files it needs. But once the configuration
files are created by executing startup.jar directly, the executable works. I
tried this workaround on both the stock 3.1.2 eclipse and JBossIDE 1.6.0, and it
works with both. 

Reference:
http://jira.jboss.com/jira/browse/JBIDE-469
Comment 1 Mike Millson 2007-04-13 10:55:21 EDT
Created attachment 152546 [details]
Startup error message.
Comment 2 Andrew Overholt 2007-04-13 11:03:39 EDT
I don't think this should be filed against the Eclipse package.  Perhaps there's
a JBossIDE bug repository somewhere?
Comment 3 Mike Millson 2007-04-13 11:15:58 EDT
I agree it's not an eclipse package issue. I wasn't sure what component to file
this against. 

It's not just a JBoss IDE issue. It also happens with the stock Eclipse 3.1.2.

Any suggestions as to what component this belongs to? 

Comment 4 Andrew Overholt 2007-04-13 11:32:30 EDT
Really it's an issue due to the use of xpcom by Eclipse 3.1.x and the fact that
RHEL5 isn't supported by them.  This is probably as good a place as any to track
it.  But really it will probably require some fixing within JBossIDE itself (ie.
patching SWT).  Ben can probably show how we fix it with 3.1.x in Fedora.
Comment 5 Max Rydahl Andersen 2007-04-13 11:43:08 EDT
could we change the title to represent the real issue ?

its general for Eclipse not just jbosside
Comment 6 Andrew Overholt 2007-04-13 11:45:21 EDT
Can you try stock 3.2.2?
Comment 7 Mike Millson 2007-04-13 12:21:54 EDT
Stock 3.2.2 starts up fine. It doesn't have this issue.
Comment 8 Andrew Overholt 2007-04-13 12:26:55 EDT
(In reply to comment #7)
> Stock 3.2.2 starts up fine. It doesn't have this issue.

Phew, I thought we got it all fixed upstream for 3.2.2 :)  I'm tempted to close
this but but perhaps only when someone files something against the offending
product (JBossIDE, RHDS, whatever) to upgrade their SDK to 3.2.2.  Please close
this when that's done.  Thanks.
Comment 9 Mike Millson 2007-04-13 15:08:00 EDT
I previously filed the following bug on the JBoss Jira:
http://jira.jboss.com/jira/browse/JBIDE-469

Just curious, what is the explanation for why I can start up using java -jar
startup.jar, yet executing the eclipse binary directly fails? And why after
doing that can I exectute the eclipse binary and it works?
Comment 10 Max Rydahl Andersen 2007-04-13 15:55:16 EDT
probably some difference between the two ways of starting and that the working 
one manages to write enough metadata so the other one doesn't hit is bug - what 
i don't know.

Comment 11 Ben Konrath 2007-04-16 04:30:40 EDT
I'm going to close this bug because the 'eclipse' component under the RHEL 5
product should be used for bugs that are in "Red Hat Eclipse", the version of
Eclipse that is integrated into RHEL 5 itself, and not for any 'layered' version
of Eclipse. 

This is not say the Fedora / Red Hat Eclipse team can't help with issues like
this, it's just the wrong place to have the discussion :-) If a similar problem
happens in the future I think the best thing to do would be to file a JBoss IDE
bug and send a message to eclipse-list if you want us to investigate.
Comment 12 Max Rydahl Andersen 2007-04-16 04:42:46 EDT
Please read the bug - this has *nothing* to do with JBoss IDE.

It's a plain vanilla eclipse + RHEL issue.

Where should issues like this be discussed if not in RHEL bug db 
(+ Eclipse bug db if an general eclipse issue is found) ?
Comment 13 Ben Konrath 2007-04-16 05:10:36 EDT
(In reply to comment #12)
> Please read the bug - this has *nothing* to do with JBoss IDE.

I did read the bug. JBoss IDE includes a plain vanilla Eclipse therefore the
problem is with JBoss IDE. And yes, I understand that it's really just the
upstream Eclipse SDK that's causing the problem but it's unrealistic to expect a
random Linux binary to work perfectly with RHEL-5 - especially one that doesn't
even claim to support RHEL-5. Red Hat Eclipse includes a number of changes to
the SDK to ensure that it works with Fedora and RHEL.

> It's a plain vanilla eclipse + RHEL issue.

Right. But like I said, the eclipse component is for "Red Hat Eclipse", the
version of Eclipse that is integrated into RHEL 5, not the upstream SDK that
doesn't support RHEL-5.

> Where should issues like this be discussed if not in RHEL bug db 
> (+ Eclipse bug db if an general eclipse issue is found) ?

If you want to include a plain vanilla Eclipse SDK in a product then you should
request RHEL-5 support for the 3.1.2 SDK in the eclipse.org bugzilla. Since they
probably won't fix such a bug, the only solution would be to include a patched
version of the SDK in your product if you want it to work with RHEL-5. Issues
surrounding this work should be discussed in JBIDE-469.
Comment 14 Max Rydahl Andersen 2007-04-16 05:23:37 EDT
ok - so we should put this in RHDS; not JBossIDE.

I've created http://jira.jboss.com/jira/browse/RHDS-44

Note: this seems to only be relevant for 3.1.2, which we won't be using 
anymore; but please fill us in with any details you have on special things that 
previously have been needed to run Eclipse on RHEL on that issue. This is 
critical to know for RHDS. Thanks.



Note You need to log in before you can comment on or make changes to this bug.