Bug 236382 - yum removed currently running kernel-debug
yum removed currently running kernel-debug
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
:
Depends On:
Blocks: FC7Target
  Show dependency treegraph
 
Reported: 2007-04-13 11:08 EDT by Dave Jones
Modified: 2015-01-04 17:29 EST (History)
3 users (show)

See Also:
Fixed In Version: 3.2.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 21:45:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2007-04-13 11:08:54 EDT
10:43 < davej> skvidal: re the magic in yum that makes sure the current running
kernel isn't removed during an upgrade..
10:43 < davej> can you add 'kernel-debug' to that list?
10:43 < skvidal> ah, probably
10:43 < skvidal> you should stop making up all these new kernel names :)
10:43 < davej> I just found out the hard way that that's a good idea ;)
10:43 < davej> I think I'm done for a while :)
10:44 < skvidal> hmm
10:44 < davej> the RHEL people did kernel-rt recently too, which should probably
be on the list
10:44 < skvidal> kernel-debug is listed
10:44 < skvidal> what ver of yum do you have?
10:44 < davej> ooh. spooky.
10:44 < davej> 3.0.6-1.fc6
10:44 < skvidal> one sec
10:45 < skvidal> hmm, it's on the installonlypkgs for that ver, too
10:45 < skvidal> so when did it get removed
10:45 < skvidal> ?
10:45 < davej> yesterday
10:45 < skvidal> you don't have anything special in your /etc/yum.conf, do you?
10:45 < skvidal> and what was the operation it was doing?
10:46 < davej> stock config.
10:46 < davej> yum -y update
10:46 < skvidal> can you send me your /var/log/yum.log?
10:46 < skvidal> or at least the last couple of days?
10:48 < davej> http://www.codemonkey.org.uk/junk/yum.log
10:49 < skvidal> this is a stock yum config for fc6?
10:50 < davej> yeah, should be
10:50 < skvidal> which kernel-debug pkg got removed?
10:50 < davej> looks like it
10:50 < davej> 2.6.20-1.2933.fc6 I think
10:51 < davej> I only have 2943 and 2944 installed now
10:52 < skvidal> okay - this seems like installonlyn took it out
10:52 < skvidal> but 2.6.20-1.2933.fc6 was running?
10:52 < davej> yeah
10:53 < skvidal> then it might be that installonlyn is doing something
not-quite-right when it comes to handling kernel-debug kernels and checking for
them being the running 
                 kernel
10:54 < davej> *nod*
10:54 < skvidal> I'll see what I can come up with
10:54 < skvidal> but could you file a bug on this against yum
Comment 1 Till Maas 2007-07-27 05:52:53 EDT
The recent yum update (yum-3.2.2-1.fc7) may introduce more problems like this:

On Monday 23 July 2007 17:46:11 updates@fedoraproject.org wrote:

> - integrated installonlyn plugin functionality - new config option
> installonly_limit will remove old, non-running kernels from your system as
> you add more. In fedora, if you had disabled the installonlyn plugin you
> will have to disable it your /etc/yum.conf with 'installonly_limit = 0'.

from man yum.conf:

| installonlypkgs
|              List of packages that should only ever be installed, never
|              updated. Kernels in particular fall into this category. 
|              Defaults to ‘kernel, 
|              kernel-smp, kernel-bigmem, kernel-enterprise, kernel-debug,
|              kernel-unsupported’. 

Imho kernel-PAE and kernel-xen are here missing, also the installonlyn 
supported some more kernel packages, here are the suffixes:

 31     for s in ("bigmem", "enterprise", "smp", "hugemem", "PAE", "rt",
 32               "guest", "hypervisor", "xen0", "xenU", "xen", "debug"):

And will the new yum also keep the the regarding -devel packages installed?

Oh, when I look into the source 
(/usr/lib/python2.5/site-packages/yum/config.py) the default values differ in 
reality:

490     installonlypkgs = ListOption(['kernel', 'kernel-bigmem',
491             'kernel-enterprise','kernel-smp', 'kernel-modules', 'kernel-debug',
492             'kernel-unsupported', 'kernel-source', 'kernel-devel'])
493     installonly_limit = IntOption(2)
494     kernelpkgnames = 
ListOption(['kernel','kernel-smp', 'kernel-enterprise',
495             'kernel-bigmem', 'kernel-BOOT'])
496     exactarchlist = ListOption(['kernel', 'kernel-smp', 'glibc',
497             'kernel-hugemem', 'kernel-enterprise', 'kernel-bigmem',
498             'kernel-devel'])

Is it correct that kernelpkgnames and exactarchlist do not include every 
kernel package name that installonlypkgs does?
Comment 2 Seth Vidal 2007-12-06 21:45:25 EST
Is this still happening? It seems to have vanished in one of the various updates.
reopen if it is, okay?

Note You need to log in before you can comment on or make changes to this bug.