Bug 236541 - [GCJ Bug] help doesn't work
Summary: [GCJ Bug] help doesn't work
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-16 10:26 UTC by Ben Konrath
Modified: 2007-11-30 22:12 UTC (History)
4 users (show)

Fixed In Version: 4.1.2-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-11 05:15:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for Classpath (2.16 KB, patch)
2007-05-03 17:22 UTC, Andrew Haley
no flags Details | Diff

Description Ben Konrath 2007-04-16 10:26:16 UTC
Version-Release number of selected component (if applicable):

eclipse 3.2.2-8

Steps to Reproduce:
1. go to Help -> Help Contents
2. get a page with "The document that you have requested is not available. The
link may be wrong or you not have the corresponding product feature installed."
instead of the Eclipse help.

Comment 1 Ben Konrath 2007-04-16 10:28:50 UTC
Here's the tomcat output of from 'eclipse -consolelog':

17-Apr-07 5:18:50 AM org.apache.catalina.startup.Embedded start
INFO: Starting tomcat server
17-Apr-07 5:18:51 AM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/5.5.20
17-Apr-07 5:18:51 AM org.apache.catalina.core.StandardHost start
INFO: XML validation disabled
17-Apr-07 5:18:52 AM org.apache.catalina.loader.WebappLoader start
INFO: Dual registration of jndi stream handler: URLStreamHandlerFactory already set
17-Apr-07 5:18:52 AM org.apache.catalina.loader.WebappLoader setClassPath
INFO: Unknown loader
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader@345789f1 class
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader
17-Apr-07 5:18:54 AM org.apache.coyote.http11.Http11BaseProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-127.0.0.1-60439
17-Apr-07 5:18:55 AM org.apache.coyote.http11.Http11BaseProtocol start
INFO: Starting Coyote HTTP/1.1 on http-127.0.0.1-60439


Comment 2 Ben Konrath 2007-04-26 04:42:59 UTC
That output is the same as what gets spit out on a working FC-6 so that won't
help with this problem.

I tested help with Sun's VM and it's working so this is a GCJ problem. I'll work
on narrowing down a test case.

Comment 3 Ben Konrath 2007-04-26 04:45:10 UTC
Tom / Andrew / Gary,

Just thought I'd let you know that this is in the pipes. I'll let you know when
I've narrowed it down a little.

Comment 4 Andrew Haley 2007-04-26 10:02:57 UTC
You say here that "output is the same as what gets spit out on a working FC-6".

I take it, then, that this bug is not an F7 regression, and has been around for
some considerable time.  Is this correct?

Comment 5 Ben Konrath 2007-04-26 15:46:39 UTC
Sorry, I wasn't clear there. What I meant to say was that text output from
-consolelog is the same as FC-6 so that doesn't help debug the problem. This is
in fact a Fedora 7 regression.

Comment 6 Andrew Haley 2007-04-26 16:10:45 UTC
OK, I'm looking now.

Comment 7 Andrew Haley 2007-05-02 15:50:16 UTC
This is because Eclipse needs MX4J.  Try this fix:

sudo ln -sf /usr/share/java/mx4j/mx4j.jar  /usr/share/java/gcj-endorsed


Comment 8 Ben Konrath 2007-05-03 05:14:57 UTC
That fixes the problem, thanks!

Comment 9 Gary Benson 2007-05-03 08:14:12 UTC
In what sense does it need it?  Does it specifically require MX4J features, or
does it just not work with libgcj's javax.management?

Comment 10 Gary Benson 2007-05-03 08:21:46 UTC
Oops, never mind, I just saw
https://www.redhat.com/archives/fedora-devel-java-list/2007-May/msg00002.html

Comment 11 Andrew Haley 2007-05-03 17:22:51 UTC
Created attachment 154051 [details]
Patch for Classpath

I have tested this bug with libgcj HEAD and it fixes the problem.

Comment 12 Andrew Haley 2007-05-04 16:34:52 UTC
Patch committed to redhat/gcc-4_1-branch, awaiting respin.


Comment 13 Andrew Haley 2007-05-10 09:24:09 UTC
To Ben Konrath

A new gcc build is at
http://koji.fedoraproject.org/koji/buildinfo?buildID=6143

Please try it.  Please close this Bugzilla entry if the bug is now fixed.


Comment 14 Ben Konrath 2007-05-11 05:15:44 UTC
Yep, the bug is fixed with gcc-4.1.2-12.


Note You need to log in before you can comment on or make changes to this bug.