Bug 236553 - environmental goal setting
environmental goal setting
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-16 08:27 EDT by Need Real Name
Modified: 2013-01-09 23:15 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-06 04:24:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2007-04-16 08:27:03 EDT
May as well throw the cat amongst the pigeons.

Later versions of Fedora should allow easy monitoring of resource usage.

How much electricity is this computer using over time?
Is it using less since I enabled ACPI? since I upgraded my kernel?

How much paper did I use last month?
Is it less since I changed the printer's default to 4-up?

How much electricity is being used when the computer is idle?

Maybe integrate into smolt. Compete to use the least energy.
Comment 1 Jesse Keating 2007-04-16 08:42:07 EDT
Much of this is visible from gnome-power-manager.  Right click on the icon and
click on power history.
Comment 2 Need Real Name 2007-04-16 11:43:04 EDT
Not centralisable though, and no extra stuff like paper usage.
Comment 3 Bug Zapper 2008-04-03 20:06:36 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 4 Bug Zapper 2008-05-13 22:46:09 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bill Nottingham 2008-12-05 14:58:21 EST
Paper seems best done at the printer level, not at the client level.

Assigning to g-p-m for some of the others.
Comment 6 Richard Hughes 2008-12-06 04:24:34 EST
(In reply to comment #0)
> Later versions of Fedora should allow easy monitoring of resource usage.

Yup, we're doing that with DeviceKit-power: http://blogs.gnome.org/hughsie/2008/11/09/gnome-power-manager-and-devicekit-power/

> How much electricity is this computer using over time?
> Is it using less since I enabled ACPI? since I upgraded my kernel?

The maximum logging duration is one week. You'll also need a power monitor like a Watts Up Pro (with USB connection) if you want to be able to plot this accurately. ACPI does not give us accurate rate data when charging or discharging and gives us no data when fully charged.

> How much paper did I use last month?

??

> Is it less since I changed the printer's default to 4-up?

Then you need to connect your printer to a WUP device, and do a study. This is quite a niche use case.

> How much electricity is being used when the computer is idle?

You can see that with gnome-power-manager already.

> Maybe integrate into smolt. Compete to use the least energy.

No, I don't think this is a good idea.

Note You need to log in before you can comment on or make changes to this bug.