Bug 236588 - git-svn is broken in git-svn-1.5.0.6-1.fc6
Summary: git-svn is broken in git-svn-1.5.0.6-1.fc6
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: git   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Wright
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-16 16:51 UTC by Tomas Winkler
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 1.5.2.1-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-18 16:42:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tomas Winkler 2007-04-16 16:51:24 UTC
Description of problem:
git-svn is broken in git-svn-1.5.0.6-1.fc6
it creates unusable .git/config 

Version-Release number of selected component (if applicable):
git-svn-1.5.0.6-1.fc6

How reproducible:
always



Steps to Reproduce:
1.git-svn multi-init -t tags -b branches -T trunk <url>
2.
3.
  
Actual results:
[core]
        repositoryformatversion = 0
        filemode = true
        bare = false
        logallrefupdates = true

[svn]
        trunk = http://<url>/trunk
        branches = http://<url>/branches
        tags = http://<url>/vtags



Expected results:
[core]
        repositoryformatversion = 0
        filemode = true
        bare = false
        logallrefupdates = true

[svn-remote "svn"]

        url = http://<url>
        fetch = trunk:refs/remotes/trunk
        branches = branches/*:refs/remotes/*
        tags = tags/*:refs/remotes/tags/*


 
Additional info:
looks like git-svn from 1.5.1.1 solves the problem

Comment 1 Fedora Update System 2007-06-09 19:24:10 UTC
git-1.5.2.1-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 2 Fedora Update System 2007-06-18 16:41:57 UTC
git-1.5.2.1-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.