Bug 23659 - X hang observed
Summary: X hang observed
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
low
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-09 16:18 UTC by Kevin L. Mitchell
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-17 16:47:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kevin L. Mitchell 2001-01-09 16:18:00 UTC
I installed RedHat 7.0 on my machine yesterday.  When I came in today,
the screensaver was not changing and would not put up a login screen.
In fact, X refused to quit on C-A-BackSpace, nor would it allow me to
switch to a virtual console.  A remote login showed that X was running
at 99% CPU; xscreensaver-command -restart hung, as did chvt 1.  It's
not clear where the problem was.  This is a 7.0 install with all the latest
updates; architecture is i686, card is ELSA GLoria Synergy.

XFree86-4.0.1-1
xscreensaver-3.25-4

Comment 1 Kevin L. Mitchell 2001-01-10 14:40:42 UTC
I've had X crash several times more.  I've disabled a couple of screensavers
that seem to be implicated: Laser and Flow.  I *think* they'll only crash the X
server if they're run immediately after another screensaver.  This is a pretty
serious bug, leaving the machine in a state where I am forced to reboot it in
order to get anything done.

Comment 2 Raul Acevedo 2001-01-15 09:21:06 UTC
I have exactly the same problem: I leave my machine, I come back and X is
completely hung.  A remote ssh showed X at 99% of the CPU; explicitly killing
X with -9 didn't help, init 3 didn't help, I had to reboot my machine.
Disabling xscreensaver fixes it; I'll try disabling the same xscreensavers
that klmitch mentioned and see if that helps.

I just installed RedHat 7 Saturday, and have been using RedHat 6.2 on this
machine since it came out without problems.  I'm using a stock install with
all the latest updates.  X driver is 3Dlabs Permedia2 (glint) for Diamond
Fire GL 2000.  PII 400Mhz (i686), 256M RAM.

Comment 3 Raul Acevedo 2001-01-15 09:48:55 UTC
I can reliably reproduce the problem by using "Laser" as the screen saver in the
GNOME
Control Center, then clicking on the Lock button in the panel (or
xscreensaver-command 
-activate).  The Laser saver starts, then X freezes after only a couple of
seconds.

Comment 4 Raul Acevedo 2001-01-15 12:42:37 UTC
Upgrading to XFree86-4.0.2-1 and xscreensaver-3.26-2 (using rawhide RPMs)
didn't help.

I forgot: I don't have a completely stock install, I am using Helix,
i mean, Ximian GNOME.  I doubt that's relevant, but just in case...

Comment 5 Mike A. Harris 2001-02-17 16:47:31 UTC
TO the original reporter, please (as always) attach X server error logs
and X configuration file to bug report.  I have no idea what an Elsa Gloria
Synergy is.  What I need to know should be in the server log though.

Comment 6 Mike A. Harris 2001-03-17 20:45:09 UTC
Please upgrade XFree86 to the latest Rawhide release.


Note You need to log in before you can comment on or make changes to this bug.