Bug 236614 - ssl socket creation failure
Summary: ssl socket creation failure
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tom Tromey
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-16 19:22 UTC by Thomas Fitzsimmons
Modified: 2014-08-11 05:46 UTC (History)
3 users (show)

Fixed In Version: 4.1.2-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-19 07:42:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
demonstrate ssl socket creation failure (248 bytes, text/x-java)
2007-04-16 19:22 UTC, Thomas Fitzsimmons
no flags Details

Description Thomas Fitzsimmons 2007-04-16 19:22:10 UTC
The attached test case throws an exception when run against libgcj because the
null localHost argument is passed through to _Jv_bind.  This test case works on
Sun's JDK (presumably -- Sun's Javadocs don't document this case -- by assuming
a default value in place of the null argument).

Comment 1 Thomas Fitzsimmons 2007-04-16 19:22:10 UTC
Created attachment 152712 [details]
demonstrate ssl socket creation failure

Comment 2 Tom Tromey 2007-04-16 20:21:22 UTC
I checked in a fix to gcc svn trunk and the RH 4.1 branch.
Hopefully it will appear in rawhide after the next GCC build.


Comment 3 Jakub Jelinek 2007-04-19 07:42:03 UTC
Should be fixed in gcc-4.1.2-9.


Note You need to log in before you can comment on or make changes to this bug.