Bug 236661 - Menu launcher does not start app
Menu launcher does not start app
Product: Fedora
Classification: Fedora
Component: system-config-lvm (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
Jim Parsons
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
Reported: 2007-04-16 21:27 EDT by Pete Zaitcev
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-05-15 15:57:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Dialog (6.34 KB, image/jpeg)
2007-04-16 21:32 EDT, Pete Zaitcev
no flags Details

  None (edit)
Description Pete Zaitcev 2007-04-16 21:27:14 EDT
Description of problem:

When invoking "Logical Volume Management" menu item, I get an error
dialog "Unknown error". Very cute (to be attached). Running
system-config-lvm works fine from a command line.

Version-Release number of selected component (if applicable):

  (yes, this is what Rawhide has currently)

How reproducible:


Steps to Reproduce:
1. Log into GNOME desktop
2. Select "System" -> "Administration" -> Logical Volume Management
   (horizontal cyan stroke for icon).
Actual results:

Error dialog.

Expected results:

Starting system-config-lvm

Additional info:

This bug may be better filed against a GNOME component, but I thought
the menus are carried by applications. I looked at this file:
Seems like an OK menu entry...
Comment 1 Pete Zaitcev 2007-04-16 21:32:28 EDT
Created attachment 152732 [details]
Comment 2 Jeremy Katz 2007-04-30 11:35:56 EDT
This really needs to be fixed for F7 final or we should probably pull
system-config-lvm from all installs.
Comment 3 Will Woods 2007-04-30 15:41:50 EDT
system-config-lvm works for me... on systems that are actively using LVM.

It does, in fact, fail with "Unknown error" on the one machine where I'm using
plain partitions. Is your machine not using LVM?
Comment 4 Will Woods 2007-04-30 17:55:34 EDT
Also interesting: It works when run as root, but not when run as a normal user.
So at least there's a workaround.. kinda.
Comment 5 Tyler Owen 2007-05-01 16:07:16 EDT
I am seeing this error as well.  If I run system-config-lvm from either the menu
or the command line as a normal user I get the error.  However if I run it from
the command line as root it works OK??  

I do have LVM configured.
Comment 6 Jim Parsons 2007-05-01 17:59:05 EDT
This is because pam was misconfigured - not using the new include directives.
This has been fixed and has been built into the latest fc7 today...and yes, I
received a dispensation from rel-eng :)

Sorry for the unpleasantness...

Note You need to log in before you can comment on or make changes to this bug.