Bug 236663 - evolution-exchange-storage coredumps when attempting to edit recipient
evolution-exchange-storage coredumps when attempting to edit recipient
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution-connector (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks: FC7Target
  Show dependency treegraph
 
Reported: 2007-04-16 21:33 EDT by Jonathan Kamens
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-03 09:07:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
bug buddy report (13.85 KB, text/plain)
2007-04-16 21:33 EDT, Jonathan Kamens
no flags Details
bug report generated by bugbuddy (12.01 KB, text/plain)
2007-06-28 11:23 EDT, William Lovaton
no flags Details
Error handling patch (529 bytes, patch)
2007-10-03 08:33 EDT, Matthew Barnes
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 354442 None None None Never
GNOME Desktop 464639 None None None Never

  None (edit)
Description Jonathan Kamens 2007-04-16 21:33:28 EDT
I have evolution-connector-2.10.0-1.fc7.

I have evolution configured to use two accounts, one Exchange and one IMAP.

I was composing a message from my IMAP account, entered and autocompleted a
recipient from my personal address book, and then right clicked on that
recipient and selected Edit.  Evolution-exchange-storage coredumped.  There is a
contact in my Exchange contacts with the same email address; I imagine this is
probably relevant.

See attached bug buddy report.
Comment 1 Jonathan Kamens 2007-04-16 21:33:28 EDT
Created attachment 152733 [details]
bug buddy report
Comment 2 William Lovaton 2007-06-28 11:03:29 EDT
I have the same problem.  I have an Exchange account and a POP account and
sometimes (it's not that hard to reproduce) evolution-exchange-storage crashes
while I'm trying to fill the fields "To:" or "Cc:" and there is data being
filtered on the fly.

I'm not really sure but I guess this only happens with the Exchange account
because it doesn't happen with POP (I don't use POP a lot though).

The annoying thing about this crash is that sometimes it happens while the the
dropdown list is open showing the possible matches and hence the mouse focus is
locked and there is no easy way to get it back.  I have to switch to a virtual
terminal using ctrl+atl+f1, log in and kill the evolution process.  This is not
really usable for an average user.

I haven't reported this upstream because this particular bug is affecting me
since Fedora Core 6 and no other distro (I have tested Ubuntu and Mandriva for a
while and they are not affected).  So this annoying bug seems specific to Fedora
and is an old one.

Fortunately, I decided to install debuginfo packages last night... and guess
what?? today in the morning I got a crash again trying to compose a mail.  The
debuginfo enabled packages are the following:

kernel-debuginfo-common-2.6.21-1.3228.fc7
kernel-debuginfo-2.6.21-1.3228.fc7
glibc-debuginfo-common-2.6-3
glibc-debuginfo-2.6-3
gtk2-debuginfo-2.10.13-1.fc7
evolution-data-server-debuginfo-1.10.2-3.fc7
evolution-debuginfo-2.10.2-2.fc7
evolution-connector-debuginfo-2.10.2-2.fc7
evolution-webcal-debuginfo-2.10.0-1.fc7

I'll attach the bug report generated by bugbuddy later on.

Cheers.
Comment 3 William Lovaton 2007-06-28 11:23:44 EDT
Created attachment 158132 [details]
bug report generated by bugbuddy

I hope this helps to solve the problem.  If you need another debuginfo package
installed, please let me know.
Comment 4 Matthew Barnes 2007-08-09 15:53:07 EDT
The stacktraces show two different crash points.

The first is from passing a NULL pointer to strlen() from within some GIOChannel
function.  The rest of the stacktrace is Bonobo vomit.

The second stacktrace shows an invocation of a NULL function pointer in
ldap_op_finished().  I think I've seen this one before and may have even fixed
it somewhere.

Thanks for the stacktraces; this helps a lot.
Comment 5 Matthew Barnes 2007-10-03 08:33:37 EDT
Created attachment 214571 [details]
Error handling patch

For Jonathan's stacktrace, it looks like something caused a
GNOME_Evolution_Addressbook_OtherError while fetching a contact, which then
caused Evolution-Data-Server's "error handling" to fall over and crash.

This patch should fix the error handling part by making sure we don't pass a
NULL string through Bonobo.  More information is required to determine what
caused the original error in the first place.
Comment 6 Matthew Barnes 2007-10-03 08:45:59 EDT
William's stacktrace looks very similar to
http://bugzilla.gnome.org/show_bug.cgi?id=354442

These are two different bugs.
Comment 7 Matthew Barnes 2007-10-03 09:07:46 EDT
There's an upstream bug that addresses the root cause of Jonathan's crash [1]. 
Both upstream bugs are marked FIXED so I'm closing this as well.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=464639

Note You need to log in before you can comment on or make changes to this bug.