Bug 236716 - /usr/bin/pygtk-demo is not executable
Summary: /usr/bin/pygtk-demo is not executable
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pygtk2   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-17 09:57 UTC by Jan Martinek
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: pygtk2-2.10.4-2.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-17 12:32:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jan Martinek 2007-04-17 09:57:45 UTC
Description of problem:
As you can see:
$ ls -l /usr/bin/pygtk-demo
-rw-r--r-- 1 root root 186 Feb  6 03:33 /usr/bin/pygtk-demo

/usr/bin/pygtk-demo is not executable (due to permissions), so it must be started as

python /usr/bin/pygtk-demo

instead of simple typing

pygtk-demo

I consider this as a minor bug, but for some users it may be confusing that 
there is something not executable in /usr/bin/. Moreover, the counterpart
"gtk-demo" is executable and it would be fine to deal the same way with both
programs.

A (temporar) workaround is
# chmod a+x /usr/bin/pygtk-demo

Comment 1 Matthew Barnes 2007-04-17 12:32:47 UTC
Thanks for reporting this.

Fixed in both Rawhide and Fedora Core 6, but I'm going to wait for something
more significant before pushing a Fedora Core 6 update.


Note You need to log in before you can comment on or make changes to this bug.