Bug 236742 - devel rescue cd fails to mount stage2.img and interprets failure wrongly.
devel rescue cd fails to mount stage2.img and interprets failure wrongly.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2007-04-17 10:15 EDT by David Timms
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-19 19:04:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hp omnibook 4150 lspci (907 bytes, text/plain)
2007-04-17 10:15 EDT, David Timms
no flags Details
hp omnibook 4150 dmesg (17.62 KB, text/plain)
2007-04-17 10:17 EDT, David Timms
no flags Details
hp omnibook 4150 lspcmcia (171 bytes, text/plain)
2007-04-17 10:17 EDT, David Timms
no flags Details
grub.conf / fstab / grub for info (1.61 KB, text/plain)
2007-04-17 10:19 EDT, David Timms
no flags Details

  None (edit)
Description David Timms 2007-04-17 10:15:13 EDT
Description of problem:
My understanding is that the rescue CD has the anaconda stage2 installer on it.
However, anaconda is ftping the stage2 image from the network install ftp server
given in the installer.

Version-Release number of selected component (if applicable):
rawhide 2007-04-17 08:31 rescue cd ftp install

How reproducible:
yes. also on a hp compaq nx6320 {1GB ram 1.8GHz, 60G wanting to upgrade.

Steps to Reproduce:
1. boot rescue CD
2. choose network install
3. enter ftp, and path.
  
Actual results: vt3
Transferring ftp:.../image/stage2.img to a fd
mntloop loop0 on /mnt/runtime as /tmp/ramfs/stage2.img fd is 24
LOOP_SET_FD failed: Device or resource busy
Error mounting /dev/loop0 on /mnt/runtime (Device or resource busy).

Expected results:
Since the stage2 is on the rescue CD, it should have mounted the CD to get the
stage2 installer.

Additional info:
In the case where the stage2 image isnt present locally, the installer failed to
mount the downloaded stage2.img, and after displaying error dialog, returns to
the FTP Setup screen.
PentiumII 366MHz, 384 MB ram, 20GB disk.
Doesn't get to vt2 being a usable console.
Comment 1 David Timms 2007-04-17 10:15:13 EDT
Created attachment 152801 [details]
hp omnibook 4150 lspci
Comment 2 David Timms 2007-04-17 10:17:17 EDT
Created attachment 152802 [details]
hp omnibook 4150 dmesg
Comment 3 David Timms 2007-04-17 10:17:52 EDT
Created attachment 152803 [details]
hp omnibook 4150 lspcmcia
Comment 4 David Timms 2007-04-17 10:19:37 EDT
Created attachment 152804 [details]
grub.conf / fstab / grub for info
Comment 5 David Timms 2007-04-17 10:22:02 EDT
actually, could be similar to bug 229704, but showing up differently due to the
CD boot method ?
Comment 6 David Timms 2007-04-18 09:41:13 EDT
Downloaded 2007-04-18 08:25
efdf1ea5f2a5d97be42fc977910384505e833dfa  FC-development-i386-rescuecd.iso
sha1sum is OK. k3b verifies CD OK.

Confirm that same is occurring. Tries to mount cdrom:/images/stage2.img, but
fails: {visible messages - no vt2 shell yet - can you get one ?}
23:17:12 INFO:  trying to mount CD device scd0
23:17:16 INFO:  mntloop loop0 on /mnt/runtime as /mnt/source/images/stage2.img
fd is 20
23:17:17 DEBUG: MD5SUM -> a258a71b15afdd8a155d24d575cb3441
23:17:17 DEBUG: skipsectors = 15
23:17:17 INFO:  supported = 1
23:17:17 INFO:  transferring
ftp://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/os/.discinfo
to a fd
--meanwhile on vt4
<7>ISO 9660 Extensions: Microsoft Joliet Level 3
<4>Unable to load NLS charset utf8
<4>Unable to load NLS charset utf8
<7>ISO 9660 Extensions: RRIP_1991A
<4>Unable to identify CD-RPM format.
<4>VFS: Can't find an ext2 filesystem on dev loop0.
====
on VT1 click OK to the server/path dialog again.
vt3:
23:23:01 INFO:  trying to mount CD device scd0
23:23:01 INFO:  transferring ftp://download.fedora.redhat.com/pub/fedora
  /linux/core/development/i386/os/images/updates.img  to a fd
23:23:03 INFO:  transferring ftp://download.fedora.redhat.com/pub/fedora
  /linux/core/development/i386/os/disc1/images/updates.img  to a fd
23:23:05 INFO:  transferring ftp://download.fedora.redhat.com/pub/fedora
  /linux/core/development/i386/os/images/updates.img  to a fd
23:23:07 INFO:  transferring ftp://download.fedora.redhat.com/pub/fedora
  /linux/core/development/i386/os/disc1/images/product.img  to a fd
23:23:09 INFO:  381092 kB are available
23:23:09 INFO:  transferring ftp://download.fedora.redhat.com/pub/fedora
  /linux/core/development/i386/os/images/stage2.img  to a fd

--meanwhile vt1: Retrieving images/stage2.img for some time and then:
  Unable to retrieve the install image.  OK.
on vt3:
23:28:49 DEBUG:  copied 81604608 bytes to /tmp/ramfs/stage2.img (complete)
23:28:49 ERROR:  LOOP_SET_FD failed: Device or resource busy
23:28:49 ERROR:  Error mounting /dev/loop0 on /mnt/runtime (Device or resource busy)

vt1: back to server/path dialog.
~~~~~
My interpretation:
- the rescue CD does have the stage2.img, but is unable to mount it.
- instead of erroring appropriately {something wrong with mounting}, it moves to
try to get the stage2.img from the ftp server.
- the ftp download succeeds. (complete)
- it attempts to mount the dl'ed stage2, and fails again (same reason I guess)
- user is then in an endless {time consuming and download wasting} loop.
Comment 7 David Timms 2007-04-18 17:52:36 EDT
This is repeatable on a totally different machine: desktop, amd athlon 2600, ide
only, 3xdisks, with same rescue as comment #6.
$ cat /etc/fstab
/dev/VolGroup00/LogVolslash /                   ext3    defaults        1 1
LABEL=/boot1            /boot                   ext3    defaults        1 2
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
/dev/VolGroup00/LogVolhome /home                ext3    defaults        1 2
...
ie lvm for the / partition - I don't know if that can be labelled like /boot can ?

On both machines, the disk(s) is detected, during the rescue boot up.
Comment 8 David Timms 2007-04-19 19:04:06 EDT
Repeated with:
$ ls -l FC-development-i386-rescuecd.iso 
-rw-r--r-- 1 root root 103387136 Apr 19 14:21 FC-development-i386-rescuecd.iso
$ sha1sum -c SHA1SUM 
FC-development-i386-rescuecd.iso: OK
# sha1sum F*
59747fcdeba04c1db6d831aa37810e3ee00b8287  FC-development-i386-rescuecd.iso

Now the stage2 installer _is_ loaded from cdrom {ie Local Installation Media
detected}.

Noted also that rescue ISO grew more than 10MB today.
Trying to use the upgrade option, the ide hard disk is detected {/dev/sda3}, and
it looks as if install would be OK (except I have lvms without labels}.
Comment 9 David Timms 2007-04-19 19:17:42 EDT
rescue cd boots and gui loads stage2 from CD also on an Dell Poweredge 1600SC
with scsi drives. Looks good.
Comment 10 David Timms 2007-05-03 09:07:35 EDT
552905763371fee09fb6bdfa5b1f2015693b93f6  FC-development-i386-rescuecd.iso
from 2007-05-02 has no problem on this same machine {hp omnibook 4150 notebook}

Note You need to log in before you can comment on or make changes to this bug.