Bug 236815 - Building pdfedit destroys /dev/null - pdfedit-0.3
Summary: Building pdfedit destroys /dev/null - pdfedit-0.3
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pdfedit   
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bernard Johnson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-17 19:26 UTC by Sammy
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-17 20:34:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sammy 2007-04-17 19:26:53 UTC
When I try to build pdfedit from the source rpm the device /dev/null
is deleted and replaced by the junk that should go to /dev/null.

Tracking this the culprit seems to be in the doc/Makefile line:

doxygen -w html /dev/null /dev/null programmer/html/doxygen.css

If I run this manually the above mentioned phenomenon happens. I am
not familiar with doxygen so I am not sure. The format of the command is:

doxygen -w html headerFile footerFile styleSheetFile

This needs an urgent fix since it can really mess things up!
Thanks

Comment 1 Bernard Johnson 2007-04-17 20:34:42 UTC
Of course this doesn't affect my buildsystem or the fedora buildsystem because
we're not building as root.

As it turns out, doxygen takes the files listed and renames then to .bak and
then does some other stuff.  If you're running as a normal user, it's not big
deal, but  as root it wrecks your /dev/null.

Nevertheless, I put a patch in to take care of it.

Look for pdfedit-0.3.0-2 when it comes out in the next day or so.


Note You need to log in before you can comment on or make changes to this bug.