Bug 236841 - when I move a message into a different folder, the next message should display
when I move a message into a different folder, the next message should display
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-17 17:46 EDT by Jonathan Kamens
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-22 13:29:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 335931 None None None Never

  None (edit)
Description Jonathan Kamens 2007-04-17 17:46:08 EDT
When I am viewing a message in the message preview, and I drag and drop that
specific message into a different folder, and it therefore disappears from the
folder I'm viewing, the next message should be selected automatically and
displayed in the message preview.  Instead, what happens is that no message ends
up being selected.
Comment 1 Milan Crha 2007-04-23 12:35:36 EDT
This bug was already fixed by upstream, patch included at bug
http://bugzilla.gnome.org/show_bug.cgi?id=332765
Comment 2 Milan Crha 2007-04-25 11:53:50 EDT
that was fixed upstream in Evolution 2.10.1
Comment 3 Jonathan Kamens 2007-04-25 12:02:41 EDT
The upstream bug was about deleting a message, not about moving a message into 
a different failure.  Deleting works as expected in 2.10.1, but moving 
doesn't.  Hence my bug report.
Comment 4 Milan Crha 2007-04-26 04:52:51 EDT
I could not reproduce this bug on 2.10.1, but on 2.8.3 I could.
I was testing it in this way:
a) I did create an empty folder in "On This Computer->Inbox".
b) have exactly 3 messages in the Inbox
c) when I move the second in the list with drag&drop over new folder, then it
disappear from Inbox and the (previously) third message is selected.
d) when I will move the second message from Inbox now (it is that last), then:
d) 1) on Evolution 2.8.3 *is not* selected message above that moved,preview is empty
d) 2) on Evolution 2.10.1 *is* selected that previous message, as expected.
Could you write here result of "rpm -q evolution", please? Only to confirm you
have installed right version. (May be also Help->About in Evolution).
May be I missed something in my process?
There is only one exception, when you have unchecked View->Hide Deleted
Messages, then that moved message is only marked as deleted and the focus in
list isn't changed.
Comment 5 Jonathan Kamens 2007-04-26 06:30:34 EDT
Well, I'll be darned.  Perhaps when I filed the bug I was using 2.10 rather than
2.10.1.  You're right, it works for me now as well.
Comment 6 Jonathan Kamens 2007-04-26 20:15:44 EDT
I *knew* I wasn't crazy.

It works for local folders.  It works for IMAP folders.  It *doesn't* work for
Exchange folders.

When you move the message you're viewing from one Exchange folder to another,
the next message isn't selected.
Comment 7 Milan Crha 2007-11-21 05:24:35 EST
OK, in that case the fix in upstream bug [1] will probably help you.
Unfortunately, it still waits for an approve. Are you OK to close this as
upstream and track the problem there?

[1] http://bugzilla.gnome.org/show_bug.cgi?id=335931
Comment 8 Jonathan Kamens 2007-11-22 13:29:48 EST
Fine with me.  Marking resolved / upstream.

Note You need to log in before you can comment on or make changes to this bug.