Bug 236846 - gmp libs not stripped
gmp libs not stripped
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gmp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2007-04-17 19:04 EDT by Jeremy Katz
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-30 15:09:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2007-04-17 19:04:47 EDT
gmp libs in /usr/lib/sse2 aren't marked executable and so don't get stripped by
rpm making them take up more space than they need to
Comment 1 Will Woods 2007-04-30 15:09:23 EDT
This seems to be fixed in current gmp:

[wwoods@metroid ~]$ rpm -ql gmp | grep sse2 | xargs file | grep ELF
/usr/lib/sse2/libgmp.so.3.3.3:   ELF 32-bit LSB shared object, Intel 80386,
version 1 (SYSV), stripped
/usr/lib/sse2/libgmpxx.so.3.0.5: ELF 32-bit LSB shared object, Intel 80386,
version 1 (SYSV), stripped
/usr/lib/sse2/libmp.so.3.1.7:    ELF 32-bit LSB shared object, Intel 80386,
version 1 (SYSV), stripped

All 3 are marked executable.

Note You need to log in before you can comment on or make changes to this bug.