Bug 236881 - Firefox doesn't install Flash plugin when it is needed and absent
Firefox doesn't install Flash plugin when it is needed and absent
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Gecko Maintainer
FF3RawhideClose
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-18 04:41 EDT by Valent Turkovic
Modified: 2008-02-22 16:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-08 17:20:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
flash bug (70.16 KB, image/png)
2008-02-08 13:04 EST, Valent Turkovic
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 416396 None None None Never

  None (edit)
Description Valent Turkovic 2007-04-18 04:41:52 EDT
Description of problem:
If you visit any page with flash content Firefox suggests installing Flash
plugin from Adobe, but install fails every time.

Version-Release number of selected component (if applicable):
Firefox 2.0.0.3

How reproducible:
Every time

Steps to Reproduce:
1. Go to a web page with any flash content
2. Try to install Flash plugin by clicking on top of the browser content window.
3. Fails to install
  
Actual results:


Expected results:
After firefox detects needed plugin I expect to download it and install it
automatically.

Additional info:
Comment 1 David L. 2007-10-06 14:43:39 EDT
this is still a problem in f8t3 AFAICT.  And I'm not having much 
luck manually installing Sun's java either.  :(
Comment 2 Matěj Cepl 2007-10-07 16:24:57 EDT
Nothing to do with this bug, but why in the world you need to install Sun's
Java? After Sun released Java under GPL, we have it now in Fedora under the name
java-1.7.0-icedtea*1.7.0.0-0.14.b18.snapshot.fc8
Comment 3 Valent Turkovic 2007-10-21 10:36:54 EDT
I still get this bug with Fedora 8 test 3 with latest updates! I tested it on
three systems and on 2 of them even after 10 and more tries it continuously
failed! On one system on 4th attempt passed, after 3 failures...

This is still an open bug, and even a serious one for novice users. Expert users
will quickly install flash with any of possible ways but for new users this is a
show stopper if they need their daily youtube fix! :(
Comment 4 Valent Turkovic 2007-11-04 14:42:19 EST
I did a clean install of Fedora 8 RC3 and I still see this bug.
Comment 5 Valent Turkovic 2007-11-04 14:47:11 EST
Suggestion: it is possible to make firefox work with yum so that it goes and
gets
http://linuxdownload.adobe.com/adobe-release/adobe-release-i386-1.0-1.noarch.rpm,
installs it and does "yum install flash-plugin -y" - after presenting user with
licence agreement.

Now we get presented with licence agreement but after we click "agree" it
downloads the plugin and failes :(

this is the video from Fedora 7, but it is the same on Fedora 8:
http://www.youtube.com/watch?v=-_ayaoEUHZ4

ps. on fedora 7 it seamed that it installs after 10 ties, but on fedora 8 it
doesn't.
Comment 6 Yijun Yuan 2007-11-04 21:24:06 EST
(In reply to comment #5)
> Suggestion: it is possible to make firefox work with yum so that it goes and
> gets
> http://linuxdownload.adobe.com/adobe-release/adobe-release-i386-1.0-1.noarch.rpm,
> installs it and does "yum install flash-plugin -y" - after presenting user with
> licence agreement.
> 

Will this install libflashsupport? I think it is reasonable to use yum if one
wants flash audio output.

Comment 7 Valent Turkovic 2007-11-05 02:29:57 EST
it installs libflashplayer.so
Comment 8 Valent Turkovic 2007-12-07 15:09:46 EST
Is anybody working on this bug?
Comment 9 Martin Stransky 2007-12-10 06:26:17 EST
I don't think so.
Comment 10 Martin Stransky 2007-12-10 06:27:18 EST
Our current priority is http://fedoraproject.org/wiki/Releases/FeatureXULRunner
but feel free to submit a patch for this issue.
Comment 11 Valent Turkovic 2007-12-19 17:16:41 EST
I can't code if my life depended on it :)
I can only nag developers with my bug submits :)
Comment 12 Matěj Cepl 2007-12-20 11:48:01 EST
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays
Comment 13 Valent Turkovic 2008-01-29 09:43:33 EST
It is the same behavior in Firefox 3 now in rawhide.
Matej have you looked at this issue? Can you please look at it if you haven't
and tell me how can I contribute in order to get this bug fixed.

I found one upstream bug that this looks related to:
https://bugzilla.mozilla.org/show_bug.cgi?id=284057

Cheers,
Valent.
Comment 14 Matěj Cepl 2008-01-29 12:37:48 EST
I am sorry, but I don't have much to tell except that you can learn programming
and fix it. We are now really busy with making FF3 working at all. Moreover, the
primary method of flash installation (aside from installing swfdec ;-)) is to
install it system-wide with yum via PackageKit (when it will be ready).
Comment 15 Valent Turkovic 2008-02-01 05:21:14 EST
ps. this is not a bug for rawhide, it is F7, F8 and looks like it will be a F9
bug also :(
Comment 16 Valent Turkovic 2008-02-01 05:33:35 EST
I got an idea how to fix this issue. If it is an upstream bug and can't be fixed
immediately maybe there is other solution.

Could there be made a firefox extension that installs flash plugin when needed?

When a flash site is loaded the extension would ask user to choose if they have
root priveleges and then it would install new yum repository and install flash
codec via yum, if the user doesn't have or doesn't want that then flash plugin
installs in only his home directory.

How does that sound?
Comment 17 Matěj Cepl 2008-02-08 11:17:44 EST
Since this bugzilla report was filed, we have seriously upgraded Gecko-related
packages in Rawhide, which may have resolved this issue. Users who have
experienced this problem are encouraged to upgrade their system to the latest
version of their distribution available.

Closing this bug as CANTFIX. Please, reopen, if this bug is still reproducable
on the latest update of your distribution.

[This is mass-closing of bugs which seem to be too old and irrelevant anymore;
we are sorry, if we are closing your bug in mistake; please, don't hesitate to
reopen, if it is still alive issue.]
Comment 18 Valent Turkovic 2008-02-08 13:01:24 EST
I updated two laptops that run rawhide and they both see this error. Reoppening.

Any idea how to troubleshoot this?

Now I get a error message window saying install.rdf file is malformed.
I'll attach a screenshot.
Comment 19 Valent Turkovic 2008-02-08 13:04:11 EST
Created attachment 294389 [details]
flash bug
Comment 20 Valent Turkovic 2008-02-08 14:23:02 EST
I started wireshark to capture packets and look for myself what is going on
while installing flash plugin.

I found out the url of the flash plugin and it is:
http://fpdownload.macromedia.com/get/flashplayer/xpi/current/flashplayer-linux.xpi

I entered that in in firefox 3 and I still got the error message!

So I downloaded the file and tried to install it localy - and it still fails :(

Looks like the problem is with the hosted file at adobe.com :( can somebody
please confirm this?

Is there some way to notify Adobe so that they fix this issue?
Comment 21 Valent Turkovic 2008-02-08 14:37:02 EST
I posted an upstream bug report:
https://bugzilla.mozilla.org/show_bug.cgi?id=416396

The insteresting thing is that it works ok on Ubuntu (as you can see by the report).
Comment 22 Matěj Cepl 2008-02-08 17:20:11 EST
I am kind of sorry, but this really belongs upstream. Closing as CLOSED/UPSTREAM
Comment 23 Mike Chambers 2008-02-08 19:00:21 EST
I have flash installed on my rawhide system and works just fine.  There was a
link that FF used initially on my desktop before yesterday that because of the
path it launched from, it didn't use the plugins correctly, but that seems to be
fixed.  I have icedtea and flash both installed and working just fine.

I don't see the problem unless you mean specifically doing it from within
firefox and using the ui?
Comment 24 Valent Turkovic 2008-02-09 05:07:09 EST
Matej it would be helpful if you tried to reproduce bug or wait for somebody
else before closing it.

Mike how have you installed flash? What method did you use? This bug is about
firefox ui based install - please read the bug report from beginning.
Comment 25 Valent Turkovic 2008-02-22 16:07:59 EST
Can there be a script on Fedora desktop that says something like this:
"Install Flash Player"

that enables adobe yum repository, presents the licence and if users agree goes
out and install the flash plugin.

Note You need to log in before you can comment on or make changes to this bug.