Bug 236890 - Can't get IP address, waits forever determining ip for eth0
Summary: Can't get IP address, waits forever determining ip for eth0
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-18 10:03 UTC by Riku Seppala
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-03 22:04:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vvv (24.30 KB, text/plain)
2007-04-18 10:03 UTC, Riku Seppala
no flags Details

Description Riku Seppala 2007-04-18 10:03:28 UTC
Description of problem:
Determining IP information for eth0... can't get ip info. Boot just stops there
if the cable is connected. 

Version-Release number of selected component (if applicable):
f7t3 fully updated 4/17/2007

How reproducible:
Unknown. Somehow I got it working yesterday and was able to yum update. Now it
just waits forever for the ip.

Steps to Reproduce:
1. ifup eth0
2.
3.
  
Actual results:
Nothing happens. Still waiting..

Expected results:
Done. Working connection.

Additional info:
HP Pavilion laptop dv9000 series (dv9237eu). AMD Turion64 X2.
/var/log/messages output:
Apr 17 15:41:48 localhost dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port
67 interval 7
Apr 17 15:41:49 localhost dhclient: DHCPOFFER from 172.16.20.5
Apr 17 15:41:49 localhost dhclient: DHCPREQUEST on eth0 to 255.255.255.255 port 67
Apr 17 15:41:53 localhost dhclient: DHCPREQUEST on eth0 to 255.255.255.255 port 67
Apr 17 15:42:06 localhost dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port
67 interval 4
Apr 17 15:42:06 localhost dhclient: DHCPOFFER from 172.16.20.5
Apr 17 15:42:06 localhost dhclient: DHCPREQUEST on eth0 to 255.255.255.255 port 67
Apr 17 15:42:12 localhost dhclient: DHCPREQUEST on eth0 to 255.255.255.255 port 67
Apr 17 15:42:17 localhost dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port
67 interval 8
Apr 17 15:42:18 localhost dhclient: DHCPOFFER from 172.16.20.5
Apr 17 15:42:18 localhost dhclient: DHCPREQUEST on eth0 to 255.255.255.255 port 67

Comment 1 Riku Seppala 2007-04-18 10:03:28 UTC
Created attachment 152883 [details]
lspci -vvv

Comment 2 Riku Seppala 2007-04-18 10:27:34 UTC
Maybe I was too hasty filing a bug. It finally got the ip, only took half an hour...
Though some might consider 30 minute boot time rather long. :)

Comment 3 Dave Jones 2007-04-19 20:24:33 UTC
Can you try installing the latest kernel update from
http://people.redhat.com/davej/kernels/Fedora ?

(todays rawhide is kinda broken, so that's the easiest way to get a working build)

We fixed a forcedeth bug just after test3 which /may/ have been reponsible for this.

Comment 4 Riku Seppala 2007-04-20 15:14:34 UTC
I'll try that next, problem is still there with 3094.

Dunno if related but I've had a lot of problems, now I found out that it all
comes to this one bug http://bugzilla.kernel.org/show_bug.cgi?id=8186
pci=noacpi helps that finally I can use X. Since there is a problem probing pci
bus, could this be symptom of that?

Comment 5 Riku Seppala 2007-05-09 08:21:16 UTC
Crap. Now I'm not sure this even is Linux bug. Yesterday I had some trouble with
my adsl-connection that I had to call my isp to get it fixed.

Long story short, the problem might be on my adsl-modem.

Comment 6 Riku Seppala 2007-08-03 22:04:48 UTC
The problem probably was with my modem.. or it is fixed. I'll mark this as notabug.


Note You need to log in before you can comment on or make changes to this bug.