Bug 236895 - cannot run eclipse in interpreted mode with gij
cannot run eclipse in interpreted mode with gij
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-18 06:36 EDT by Ben Konrath
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version: 4.1.2-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-26 03:07:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stack trace showing errors (24.96 KB, text/plain)
2007-04-18 06:38 EDT, Ben Konrath
no flags Details
Test case (20.00 KB, application/octet-stream)
2007-04-23 12:29 EDT, Andrew Haley
no flags Details

  None (edit)
Description Ben Konrath 2007-04-18 06:36:08 EDT
Description of problem:

Running eclipse in interpreted mode with gij is currently not working. The
current eclipse build proceedure requires eclipse to be run in interpreted mode
with gij so that the shared libraries that are packed within the jarred plugins
can be extreacted.

The last successful eclipse build without a workaround (see below for details)
was eclipse-3.2.2-7 built on Wed 21 Mar 2007 01:54:04 AM EDT with
gcc-java-4.1.2-5 which was built on Sat 17 Mar 2007 10:15:49 AM EDT. I first
became aware of the problem on Mon 2 Apr 2007 07:55:21 AM EST when Matt Domsch
posted a message indicating that the eclipse package was not building:

https://www.redhat.com/archives/fedora-devel-list/2007-April/msg00046.html

The gcc package was re-built twice between the successful eclipse build
(3.2.2-7) and when the failure was first discovered: gcc-java-4.1.2-6 was built
on Tue 27 Mar 2007 07:30:11 PM EDT and gcc-java-4.1.2-7 was built on Thu 29 Mar
2007 09:09:59 AM EDT. I think the problem was introduced with a change in one of
those builds.

Version-Release number of selected component (if applicable):

gcc-java-4.1.2-8

How reproducible:

Always.

Steps to Reproduce:

The easiest way to reproduce this issuee is to run eclipse in rawhide in
interpreted mode rather than waiting hours for a build to complete.

1. sudo mv /usr/lib/gcj/eclipse /root
2. sudo rebuild-gcj-db
3. eclipse -consolelog
4. notice the stack trace (attached) and that eclipse cannot display the welcome 
   screen becuase of this error.

Additional info:

I added 'BuildRequires: eclipse-pde' to the eclipse spec file as a workaround
for this issue but that probably wasn't a good idea. Another solution would be
to try to run the shared library extraction stuff after aot-compile-rpm but I'd
like to get this fixed even if I am able to work around this issue so that
plugins installed with the update manager will work.

I added some printfs to 
org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:402
and noticed that the org.eclipse.equinox.registry_3.2.1.R32x_v20060814 bundle
fails to find org.eclipse.core.runtime.Plugin with gij but with the Sun 1.5 VM
the equinox.registry bundle does not even appear in the printf output. Not sure
if this helps though. I can post logs of this if it will be helpful.
Comment 1 Ben Konrath 2007-04-18 06:38:27 EDT
Created attachment 152884 [details]
stack trace showing errors
Comment 7 Andrew Haley 2007-04-20 05:39:30 EDT
I have duplicated this bug with libgcj-4.1.2-8 in x86_64.
Comment 8 Andrew Haley 2007-04-23 12:29:44 EDT
Created attachment 153292 [details]
Test case

Untar this, then

cd pr236895
java t2
Comment 9 Jakub Jelinek 2007-04-26 03:07:39 EDT
Should be fixed in gcc-4.1.2-11.

Note You need to log in before you can comment on or make changes to this bug.