Bug 236906 - up2date --nox attempts to connect to x11 server
up2date --nox attempts to connect to x11 server
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Beth Nackashi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-18 07:54 EDT by Lubomir Kundrak
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-21 05:21:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Kundrak 2007-04-18 07:54:07 EDT
Description of problem:

In case DISPLAY environment variable is set, up2date attempt
to connect to x11 server regardless of --nox option given on
a command line.

Version-Release number of selected component (if applicable):

[root@rhel4 mail]# rpm -q up2date
up2date-4.4.69-25
[root@rhel4 mail]# cat /etc/redhat-release
Red Hat Enterprise Linux AS release 4 (Nahant Update 4)
[root@rhel4 mail]#

Steps to Reproduce:

[root@rhel4 mail]# up2date --nox -i sendmail-cf
X11 connection rejected because of wrong authentication.
[root@rhel4 mail]# unset DISPLAY
[root@rhel4 mail]# up2date --nox -i sendmail-cf

Fetching Obsoletes list for channel: rhel-i386-as-4...
...
Comment 1 Lubomir Kundrak 2007-09-21 05:21:48 EDT
Closing this. Probably noone needs this fixed in RHEL anyways.

Note You need to log in before you can comment on or make changes to this bug.