Bug 236913 - iptraf can't be rebuilt
iptraf can't be rebuilt
Status: CLOSED DUPLICATE of bug 233934
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iptraf (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-18 08:41 EDT by Mykola Ulianytskyi
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-02 09:05:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
iptraf-3.0.0-kernheaders.patch fix build issue (955 bytes, text/x-patch)
2007-04-18 08:41 EDT, Mykola Ulianytskyi
no flags Details

  None (edit)
Description Mykola Ulianytskyi 2007-04-18 08:41:44 EDT
Description of problem:
   iptraf can't be rebuilded

Version-Release number of selected component (if applicable):
   iptraf 3.0.0-5.el5
   kernel-headers 2.6.18-8.el5

Steps to Reproduce:
   rpmbuild -ba iptraf.spec

...
gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -DWORKDIR=\"/var/lib/iptraf\"
-DLOCKDIR=\"/var/lock/iptraf\" -DLOGDIR=\"/var/log/iptraf\"
-DEXECDIR=\"/usr/bin\" -I/usr/include/ncursesw -I../support
         -DVERSION=\"3.0.0\" -DPLATFORM=\"Linux/i386\"     -c -o ifstats.o ifstats.c
In file included from ifstats.c:34:
/usr/include/linux/if_packet.h:52: error: expected specifier-qualifier-list
before '__u32'
...
Comment 1 Mykola Ulianytskyi 2007-04-18 08:41:44 EDT
Created attachment 152895 [details]
iptraf-3.0.0-kernheaders.patch fix build issue
Comment 2 Marcela Mašláňová 2007-04-19 09:29:55 EDT
I appreciate your patch, I've already fixed it in a devel.
Comment 5 Marcela Mašláňová 2007-05-02 09:05:25 EDT
Duplicate of rhbz#233934

*** This bug has been marked as a duplicate of 233934 ***

Note You need to log in before you can comment on or make changes to this bug.