Bug 236918 - Remove alsactl from /etc/modprobe.conf
Summary: Remove alsactl from /etc/modprobe.conf
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kudzu   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 236285
TreeView+ depends on / blocked
 
Reported: 2007-04-18 13:27 UTC by Martin Stransky
Modified: 2014-03-17 03:06 UTC (History)
1 user (show)

Fixed In Version: 1.2.70-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-20 01:52:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (2.51 KB, patch)
2007-04-18 13:27 UTC, Martin Stransky
no flags Details | Diff

Description Martin Stransky 2007-04-18 13:27:02 UTC
Description of problem:

Because of Bug 236285, we need to move ALSA volume settins from /etc to
/etc/alsa/. There's updated salsa utlity which can handle it, so we don't have
to care about alsactl any more. Proposed patch is attached.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Martin Stransky 2007-04-18 13:27:02 UTC
Created attachment 152904 [details]
proposed patch

Comment 2 Bill Nottingham 2007-04-19 17:42:21 UTC
I'm wondering if we should just stop writing the lines entirely - who actually
removes modules?

Comment 3 Martin Stransky 2007-04-19 19:44:01 UTC
Modules aren't removed unless you have an usb sound card and you detach it.
Unfortunatelly, kudzu doesn't handle the usb devices and can't write approprite
lines to /etc/modprobe.conf.

I think we can remove writing the lines from kudzu and handle /etc/modprobe.conf
by system-config-soundcard which can detect the USB devices.

Comment 4 Bill Nottingham 2007-04-20 01:52:49 UTC
Lines removed in 1.2.70-1. The 'index' lines will still be written.


Note You need to log in before you can comment on or make changes to this bug.